Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Даны натуральное число n и последовательность целых чисел а1, а2,…,аn.. Определить количество тех членов последовательности, которые нечетны . Найти

10-11 класс

сумму членов последовательности, кратных 11. Составить блок-схему алгоритма, написать программу.

Stopka789 10 мая 2014 г., 2:07:53 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sfergege
10 мая 2014 г., 4:58:02 (9 лет назад)

var a:array[1..1000] of longint;

 kol, s, i, n : longint;

begin

 

readln(n);

 

for i:=1 to n do read(a[i]);

 

s := 0;

kol := 0;

for i:=1 to n do 

begin

  if (a[i] mod 11 = 0) then s := s + a[i];  // summa elementov

  if (a[i] mod 2 = 1) then kol := kol + a[i];  // kolichestvo nechetnyx

end;

 

writeln (kol, ' ', s);

end;

 

 

 

после //  нужно удалить ... сорри, что нет блок схемы

Ответить

Другие вопросы из категории

Помогите пожалуйста!!! Кто чем может :)

При проектировании БД были определены следующие отношения: МАГАЗИН (Номер_магазина, Тип, Адрес, Директор, Телефон) ; ОТДЕЛ (Название_отд, Заведующий, Телефон) ; ПРОДАВЕЦ (Табельный_ном. , Фамилия, Имя, Отчество, Категория) Являются ли эти отношения связанными? Добавьте всё, что необходимо для их связи; изобразите схему БД в графическом виде.

Читайте также

Ребят, помогите пожалуйста объяснить задачи!!!

В целочисленной
последовательности есть нулевые элементы. Создать массив из номеров этих
элементов.



Program
Om1;

Uses
crt;

Var

a :array
[1..100] of real;

i,n,j :
integer;

x :
array [1..100] of real;

Begin

clrscr;

write('n=');readln(n);

for i:=1
to n do

readln(a[i]);

j:=1;

for i:=1
to n do

if
a[i]=0 then

begin

x[j]:=i;

j:=j+1

end;

for i:=1
to j-1 do

write(x[i],' ');

End.


Дана последовательность
целых чисел а1, а2….аn.
Выяснить какое число встречается раньше, положительное или отрицательное.


Program
num2;

Uses
crt;

VAr

a :array
[1..100] of real;

i,n :
integer;

Begin

clrscr;

write('n=');readln(n);

for i:=1 to n do

readln(a[i]);

for i:=1
to n do

begin

if
a[i]<>0 then

if
a[i]>0 then

begin

writeln('Положительное встречается раньше');

break

end else

begin

writeln('Отрицательное встречается раньше');

break

end;

end;

End.


Дана последовательность
действительных чисел а1, а2….аn. Выяснить будет ли она возрастающей.


Program
num4;

Uses
crt;

Var

a :
array [1..100] of real;

i, n, j
:integer;

Begin

clrscr;

write('n=');readln(n);

a[n+1]:=a[n]+1;

for i:=1
to n do

readln(a[i]);

j:=0;

i:=1;

while
i<n do

begin

if
a[i]<a[i+1] then

begin

j:=j+1;

i:=i+1

end

else

begin

writeln('Последовательность невозрастающая');

break

end;

end;

if i=n then writeln('Последовательность возрастающая');

End.




Найти самую большую цифру
целого числа.


Program
rar;

uses
crt;

var
n:longint;

b:byte;

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

Последовательность чисел Фибоначчи образуется так: первый и второй члены последовательности равны единице, каждый следующий член равен сумме двух

предыдущих. (1,1,2,3,5,13...).Дано натуральное число n. n>=3. а)Найти k-й член этой последовательности; б)Для заданного n определить верно ли, что сумма первых n-членов последовательности есть четное число. Помогите, нужно составить программу для решения данных задач!

Даны натуральное число n и последовательность целых чисел а1, а2,…,аn..Все

положительные элементы уменьшить в 2 раза. Составить блок-схему алгоритма, написать программу



Вы находитесь на странице вопроса "Даны натуральное число n и последовательность целых чисел а1, а2,…,аn.. Определить количество тех членов последовательности, которые нечетны . Найти", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.