Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Элементы заданной матрицы A(m,n)-целые числа. Напишите программу вычисляющую сумму и произведения элементов, которые кратны 3 или 2.

10-11 класс

ZaecV 07 окт. 2013 г., 19:54:05 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dromara
07 окт. 2013 г., 22:44:59 (10 лет назад)

var
  a                      : array [1..100,1..100] of longint;
  n,m,i,j,sum,mnj : longint;
begin
  readln(n,m);
  for i:=1 to n do 
    for j:=1 to m do read(a[i,j]);
  sum:=0;
   mnj :=1;
 for i:=1 to n do 
    for j:=1 to m do 
      if (a[i,j] mod 3)=0 or ((a[i,j] mod 2)=0) then begin sum:=sum+a[i,j]); mnj:=mnj*a[i,j]; end;
  writeln(sum,' ',mnj);
 
end.

Ответить

Другие вопросы из категории

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

Помогите пожалуйста написать программу)))

Даны три числа, вывести их на экран в порядке возрастания.

Решите пожалуйста!

Это информатика, 10 класс
Вопросы на фотографии
Номера 5 и 6 не надо решать

Какие схемы называются логическими элементами?

1) Схемы, выполняющие считывание

2) Схемы, запоминающие выходные сигналы от других элементов схемы

3) Электронные схемы, выполняющие усиление электрических сигналов

4) Электронные схемы, выполняющие простейшие логические операции

Читайте также

Задание #1

Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.

Задание #2
Напиши программу, вычисляющую стоимость покупки с учетом 10 %-й скидки, которая предоставляется только в том случае, если сумма покупки больше 1000 рублей.

Задание #3
Напиши программу, вычисляющую сумму всех четных чисел от 1 до N.

Задание #4
Напиши программу, вычисляющую среднее арифметическое заранее созданного массива случайных чисел из 10 элементов.

Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы попытайтесь

написать программу, которая отвечает на вопрос " существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"

Входные данные: Два числа N(1<=N<=10000000000),k (1<=k<=100)
Выходные данные: Программа выводит два таких числа, если они существуют,"NO"- если нет.

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.



Вы находитесь на странице вопроса "Элементы заданной матрицы A(m,n)-целые числа. Напишите программу вычисляющую сумму и произведения элементов, которые кратны 3 или 2.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.