Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Паскаль. Розгалудження.

5-9 класс

Скласти програму, яка дає довідку про назву столиці (St) та про кількість населення (nas, у мільйонах) деякої країни( kr) з такого переліку: Угорщина, Італія, Україна.

Т1а2 19 нояб. 2013 г., 17:46:32 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mishenkosnego
19 нояб. 2013 г., 19:46:34 (10 лет назад)

const
  St: array[1..3] of string = ('Будапешт', 'Рим', 'Киев');
  Nas: array[1..3] of real = (9.9, 61.5, 44.3);
  Kr: array[1..3] of string = ('Венгрия', 'Италия', 'Украина');
  {Сведения о численности населения приведены по данным ресурса
   CountryMeters по состоянию на 03.07.2014}

var
  i: integer;

begin
  write('Введите 1-Венгрия, 2-Италия, 3-Украина -> ');
  readln(i);
  if i in [1..3] then
    writeln('Страна- ', Kr[i], ', столица- ', St[i], ', население (млн.чел.)- ', Nas[i])
  else
    writeln('Неверный ввод!')
end.

Тестовое решение:

Введите 1-Венгрия, 2-Италия, 3-Украина -> 2
Страна- Италия, столица- Рим, население (млн.чел.)- 61.5



Ответить

Другие вопросы из категории

1.Решите задачу

Сообщение о том,что ваш друг живёт на 10 этаже,несёт 4 бита информации.Сколько этажей в доме?
2.переведите 3 мб в биты.

Читайте также

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Паскаль, в его первоначальном виде, представляет собою чисто процедурный язык.

Простейшая программа на Паскале будет выглядеть следующим образом:
program upr;
begin
writeln ( ? ); {оператор вывода строки}
end.
Определи, какая фраза пропущена на месте вопросительного знака?
’Hello, World!’
“Lorem ipsum”
Just Another Perl Hacker

Найти алгоритм минимума из 3х целых чисел на паскале+ составить блок -схему.

ПОЖАЛУЙСТА,ХОТЯ БЫ НА ПАСКАЛЕ СОСТАВЬТЕ!

ПРОГРАММИРОВАНИЕ,ПАСКАЛЬ.РЕБЯТА,УМОЛЯЮ,ПОМОГИТЕ.

Задали написать программу на язвке паскаль:вычислить и вывести на экран 8 первых элементов ряда если каждый элемент задан формулой а1= i/sin*i



Вы находитесь на странице вопроса "Паскаль. Розгалудження.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.