Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

дано вещественное число х.Найдите значения полинома:

10-11 класс

4х^5-х^3+х^2-х+4

Zolotuhinadarj 04 марта 2014 г., 3:47:09 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rtegfhbnv
04 марта 2014 г., 4:53:22 (10 лет назад)

program Count;
uses crt;
var x,y:real;
begin
clrscr;
write('Введите Х: ');
readln(x);
y:= 4*x*sqr(sqr(x))-x*sqr(x)+sqr(x)-x+4; {В паскале sqr(x) означает  х²}
writeln('X = ', Y);
readln
end.

Ответить

Другие вопросы из категории

Составление таблицы функции y=a³/(a²+x2) для x , принадлежащих отрезку [-1;1] с шагом 0.1. Так как пример цикла типа for должен быть целочисленным ,

удобнее использовать цикл while, в котором значение x можно изменять при каждом шаге на Dx=0.1

Трое мужчин - Валиев, Карманов и Нугаев – женаты: один – на Марьям, другой – на Альбине, третий – на Гульнур. У каждой пары есть сын: у одной –

Фердинанд, у другой – Дамир, у третьей – Руслан. Вот что ещё известно: Нугаев – не муж Гульнур и не отец Дамира; Марьям – не жена Карманова и не мать Фердинанда. Если отец Фердинанда – Карманов или Нугаев, то Гульнур – мать Руслана. Если Гульнур – жена Карманова, то Альбина – не мать Фердинанда. Назовите фамилии сыновей и жён.

срочно помогите пожалуйста)))

Написала код алгоритма в Visual Basic, который правильно считает элементы массива А, В, С и почему то не правильно считает Z по формуле с этими найденными

числами. В чём ошибка? вот код:
Private Sub Command1_Click()

' Описание переменных
Dim N As Single
Dim M(15) As Single
Dim A As Single
Dim B As Single
Dim C As Single
Dim Z As Single
' Описание переменных
' Вод исходных данных
N = 0
M(I) = 0
A = 1
B = 0
C = 0
' Ввод исходных данных

' Реализация алгоритма
For I = 1 To 15
N = Int(Text1.Text)
M(I) = Val(InputBox("Ввести элементы"))
Print Str(M(I))
Next I
For I = 1 To 15
If M(I) > 0 And M(I) <> 0 Then
A = A * M(I)
End If
Next I
For I = 15 To 0 Step -1
If I Mod 2 = 0 Then
If M(I) > 0 Then
B = M(I)
I = 0
End If
End If
Next I
For I = 1 To N Step 1
S = S + M(I)
Next I
C = S / N
Z = С + (А + В/ А * В + 1)
' Реализация алгоритма

' Вывод результата
Text2.Text = Str(A)
Text3.Text = Str(B)
Text4.Text = Str(C)
Text5.Text = Str(Z)
' Вывод результата
End Sub

Читайте также

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

1. Дано шестнадцатиричное число 12CD. Получить его двоичный аналог.

2. Дано десятичное число X=563. Представить его в ячейке.
3. Дано десятичное число X= -62. Представить его в восьмиразрядной ячейке.
4. Дана шестнадцатеричная запись числа X=FB32 в ячейке. Получить исходное число в десятичной системе.

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

1.Дано натуральное число:

a) найти произведение цифр числа б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
3.Из данного натурального числа удалить все цифры А (а вводятся с клавиатуры).

Написать программы в паскале и желательно блок-схему, но можно и без нее.
Помогите пожалуйста)



Вы находитесь на странице вопроса "дано вещественное число х.Найдите значения полинома:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.