Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дано слово из 12 букв. Поменять местами его трети следующим образом: первую треть слова разместить на месте третьей, вторую треть на месте первой, третью

5-9 класс

треть на месте второй.

ывйцу 23 февр. 2015 г., 20:32:29 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
12345ирина
23 февр. 2015 г., 22:44:22 (9 лет назад)

program buldog78;
var s,s1,s2,s3:string;
    i,h:integer;
begin
write('S=');
read(s);
h:=length(s) div 3;
for i:=1 to h do
s1:=s1+s[i];
for i:=h+1 to h*2 do
s2:=s2+s[i];
for i:=h*2+1 to h*3 do
s3:=s3+s[i];
writeln('S=',s2,s3,s1);
end.

Ответить

Другие вопросы из категории

Читайте также

ПОМОГИТЕ!

1)В слове ГЕОЛОГИЯ все гласные буквы заменили на те,что идут в слове перед ними.Какие буквы присутствуют в полученной последовательности букв?
А) Е Б)О В)Ю

2)В слове ПОЛДНИК третью букву поставили на предпоследние место,а в том,что получилось,третью с конца букву еще раз написали справа от буквы "К".Что может выйти,если строго один раз поменять местами две соседние буквы результата?
А)ПОИДНЛКН Б)ПОДИНЛКИ В)ПОДИЛНКН

3)В слове ЧАЙНИК все буквы поменяли на находящиеся по соседству с ними в алфавите.Что в результате могло получиться?
А)ЦАКМИЛ Б)ШБИМКЛ В)ЦБКОЙЙ

все пятибуквенные слова составленные из латинских букв F,N,S ЗАПИСАНЫ В АЛФАВИТНОМ ПОРЯДКЕ

1.FFFFF
2.FFFFN
3.FFFFS
4FFFNF
5.........
.Определите слова которые будут идти в этом списке 7,27,90,101,196.Возможно вам будет проще ответить на третий и четвертый вопрос если вы будете знать,что на 99-ом месте в этом списке стоит строка NFNSS
в ОТВЕТЕ НУЖНО ЗАПИСАТЬ ПЯТЬ СТРОК СОСТОЯЩИХ ИЗ ЛАТИНСКИХ БУКВ.Ответ на каждое задание нужно писать в отдельной строке.(в 1 строке слово стоящее 7-ым,во 2-ой слово стоящее 27-ым,и далее 90,101 и 196 также)Порядок записи слов менять нельзя

ПОМОГИТЕ ХОТЬ ЧТО МОЖИТЕ ОЧЕНЬ ПРОШУ 1. У исполнителя Калькулятор две команды, которым присвоены номера: 1. прибавь 2 , 2. умножь на 3

Первая из них увеличивает число на экране на 2, вторая – утраивает его. Запишите порядок команд в алгоритме получения из числа 0 числа 28, содержащем не более 6 команд, указывая лишь номера команд (например, программа 21211 это программа умножь на 3 прибавь 2 умножь на 3 прибавь 2 прибавь 2 которая преобразует число 1 в число 19.) 2. Некоторый алгоритм из одной цепочки символов получает новую цепочку следующим образом. Сначала записывается исходная цепочка символов, после нее записывается исходная цепочка символов в обратном порядке, затем записывается буква, следующая в русском алфавите за той буквой, которая в исходной цепочке стояла на последнем месте. Получившаяся цепочка является результатом работы алгоритма. Например, если исходная цепочка символов была ЛЕС, то результатом работы алгоритма будет цепочка ЛЕССЕЛТ. Дана цепочка символов ЕН. Какая цепочка символов получится, если к данной цепочке применить алгоритм дважды (то есть к данной цепочке применить алгоритм, а затем к результату его работы еще раз применить алгоритм)? 3. От разведчика была получена следующая шифрованная радиограмма, переданная с использованием азбуки Морзе: – • – • – • • – – • – – При передаче радиограммы было потеряно разбиение на буквы, но известно, что в радиограмме использовались только следующие буквы: Т А У Ж Х – • – • • – • • • – • • • • Определите текст радиограммы (напишите). 4. В кодировке КОИ-8 каждый символ кодируется одним байтом. Определите информационный объем сообщения в битах из 30 символов в этой кодировке. 5. Определите значение переменной m после исполнения данного алгоритма k:=2 m:=k-2 k:=m * k +5 m:=m+2 7. Определите значение переменной z после выполнения следующего фрагмента программы x:=22 ; y:=12; y:=3*x-4*y; if x>y then z:=3*x+y else z:=2+x*y

Дано слово "Процессор". Используя буквы входящие в это слово в качестве алфавита(буквы могут быть только прописными), были составлены все возможные слова

из четырех букв, такие что соседние буквы в каждом слове различны и все слова отличаются друг от друга хотя бы одной буквой. Слова, состоящие из одинаковых букв, но стоящих в разном порядке считаются различными. Сколько получилось таких слов? В ответе укажите целое число.
Можно пожалуйста с подробным решением?



Вы находитесь на странице вопроса "Дано слово из 12 букв. Поменять местами его трети следующим образом: первую треть слова разместить на месте третьей, вторую треть на месте первой, третью", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.