Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите пожалуйста!)

10-11 класс

Задание 3.
Дана квадратная матрица размерностью N. Подсчитать количество отрицательных элементов по строкам. ВВЕДИТЕ РАЗМЕРНОСТЬ МАТРИЦЫ N:-
->5
Через пробел введите N*N элементов массива:
--> 10 3 2 6 8
3 -2 7 -1 4
4 5 -10 9 -12
5 0 2 4 5
6 3 -3 -5 2
Количество: 0,2,2,0,2

Дитяя 02 сент. 2014 г., 15:56:28 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
KRUT
02 сент. 2014 г., 17:28:20 (9 лет назад)

Решение
var
a: array [1..30, 1..30] of integer;
i, j, n, k: integer;

begin
readln(n);
for i:=1 to n do
 for j:=1 to n do read(a[i,j]);
for i:=1 to n do
begin
k:=0;
 for j:=1 to n do
 if a[i, j]<0 then inc(k);
write(k, ' ');
end;
end.

Если есть вопросы, пиши.

+ 0 -
Pavlikpavlov9
02 сент. 2014 г., 19:58:07 (9 лет назад)

Через язык Си

Ответить

Другие вопросы из категории

Для

таблицы истинности логической функции составить:
совершенную
дизъюнктивную и конъюнктивную формы функции,

ПАСКАЛЬ!!!

Нужно создать программу,которая проверяет принадлежность символа,вводимого с клавиатурі, символам %,^,&

Читайте также

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Помогите пожалуйста!) Напечатать программу в паскале......

Пожалуйста...Срочно...Завтра крайний срок сдачи...Помогите...

Дан массив строк без пробелов. Напечатать строки, вторая половина которых не содержит цифры.



Вы находитесь на странице вопроса "Помогите пожалуйста!)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.