Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

cформировать одномерный массив из 15 элементов с помощью случайных чисел, получить новый массив каждый элемент, которого равен кубу соответствующего

5-9 класс

элемента исходного массива, в полученном массиве вывести элементы стоящие на нечетных местах. Напишите, пожалуйста программу на языке Pascal

Llllllleeerrraaa 18 окт. 2014 г., 19:29:50 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mariyasemenova2
18 окт. 2014 г., 21:10:28 (9 лет назад)

var
 A:array[1..15] of integer;
 i:integer;
begin
 randomize;
 for i := 1 to 15 do

 writeln('Исходныйы массив:');
 begin
   A[i] := random(21) - 10;
   write(A[i], ' ');
   A[i] := A[i] * A[i] * A[i];
 end;
 writeln;

  writeln;

writeln('Нечетные элементы преобразованного массива')
 i := 1;
 while i <= 15 do
 begin
   write(A[i], ' ');
   i := i + 2;
 end;
 readln;
end.

Ответить

Другие вопросы из категории

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

кто такой Клод Шеннон
Ста­тья, на­бран­ная на ком­пью­те­ре, со­дер­жит 32 стра­ни­цы, на каж­дой стра­ни­це 40 строк, в каж­дой стро­ке 48 сим­во­лов. Опре­де­ли­те раз­мер

ста­тьи в ко­ди­ров­ке КОИ-8, в ко­то­рой каж­дый сим­вол ко­ди­ру­ет­ся 8 би­та­ми.1) 120 Кбайт
2) 480 байт
3) 960 байт
4) 60 Кбайт

Читайте также

Последняя задача...если вы мне поможете,то в аттестате 4 будет....пожалуйста помогите.вот:Сформируйте массив содержащий 15 элементов,с помощью датчика

случайных чисел.Получите новый массив,каждый элемент которого равен удвоенному соответствующему элементу исходного массива.В полученном массиве найдите максимальный элемент среди элементов,номера которых кратны трем.Выведите на экран исходные и полученные результаты

I В паскале с помощью генератора случайных чисел получить двузначное число и

1) найти и вывести сумму его цифр
2) сформировать число, в котором поменяются разряды (допустим будет число 13, нужно сделать, что бы было 31 и т.п.)
II В паскале с помощью генератора случайных чисел получить трехзначное число и определить, является ли оно полимером (например 121 - является, 123 - нет)

I В паскале с помощью генератора случайных чисел получить двузначное число и

1) найти и вывести сумму его цифр
2) сформировать число, в котором поменяются разряды (допустим будет число 13, нужно сделать, что бы было 31 и т.п.)
II В паскале с помощью генератора случайных чисел получить трехзначное число и определить, является ли оно полимером (например 121 - является, 123 - нет)

решить через паскаль через массивы)) 1.Дан одномерный массив из 10 элементов. Заменить все большие 7 члены массива числом 7. Найти количество

таких членов.

2.Дан массив из 10 элементов. Найти количество элементов с четными индексами.

3.Дан массив из 10 элементов. Найти наибольший элемент массива.

1 Задание:сформируйте и выведите на экран массив из девяти элементов,каждые три последовательных элемента которого составлены по следующему правилу:

1-й равен значению текущего индекса, увеличенному на 3; 2-й равен квадрату предыдущего индекса; 3-й равен сумме двух предыдущих элементов. 2 Задание : сформируйте массив, содержащий 15 элементов ,с помощью датчику случайных чисел. Получите новый массив,каждый элемент которого равен сумме соответствующего элемента исходного массива и его индекса. В полученном массиве удвойте элементы,которые меньше заданного с клавиатуры числа А,и найдите их сумму . Выведите на экран исходные и полученные результаты .



Вы находитесь на странице вопроса "cформировать одномерный массив из 15 элементов с помощью случайных чисел, получить новый массив каждый элемент, которого равен кубу соответствующего", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.