Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Дана вещественная квадратная матрица А порядка n. Найти среднее

10-11 класс

арифметическое среди положительных элементов матрицы, находящихся на
главной и побочной диагоналях. Выдать сообщение, если таких элементов нет.

Viktorpikunov 22 апр. 2013 г., 22:18:44 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Панда55
23 апр. 2013 г., 1:09:40 (11 лет назад)

VAR
   ans: Real;
   n, i, j, kol: Integer;
   a: Array of Array of Real;
BEGIN
   Read(n); SetLength(a, n+1);
   For i := 1 to n do SetLength(a[i], n+1);

   For i:= 1 to n do 
      For j := 1 to n do Read(a[i][j]);

   For i := 1 to n do
      If (a[i][i] > 0) then begin Inc(kol); ans := ans + a[i][i]; End;

   If (kol > 0) then begin Writeln('Ср. ар. с гл. диагонали = ', ans / kol); kol := 0;ans := 0; End
   Else Writeln('Элементов > 0 на гл. диагонали - нет !');

   For i := 1 to n do
      If (a[i][n-i+1] > 0) then begin Inc(kol); ans := ans + a[i][n-i+1]; End;

   If (kol > 0) then Writeln('Ср. ар. с поб. диагонали = ', ans / kol)
   Else Writeln('Элементов > 0 на поб. диагонали - нет !');
END.

Ответить

Читайте также

№1 Дана действительная квадратная матрица порядка n. Найти произведение четных элементов.

№2 В данном одномерном массиве Х[1..n] найти сумму отрицательных элементов , кратных 7.

Написать программу на С++. Дана целочисленная квадратная матрица произвольной размерности. Сформировать одномерный массив, в который поместить элементы

двумерной матрицы, находящиеся над побочной диагонали; упорядочить их по возрастанию и найти их среднее арифметическое.



Вы находитесь на странице вопроса "Дана вещественная квадратная матрица А порядка n. Найти среднее", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.