Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Помогите решить задачи по информатике.Очень нужно.

10-11 класс

Juliya312 11 окт. 2014 г., 17:15:00 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
2902001626
11 окт. 2014 г., 18:05:47 (9 лет назад)

 

Решение первой задачи 

 

program test;
uses crt;
const n=5;
var a: array [1..n, 1..n] of integer;
i,j,min: integer;
begin
clrscr;
for j:=1 to n do begin
writeln ('Введите элементы ',j, ' строки массива');
for i:=1 to n do
readln (a [i,j]);
end;
for j:=1 to n do begin
writeln ();
for i:=1 to n do
write (' ',a [i,j]);
end;
writeln ();
writeln ('Результат');
for j:= 1 to n do begin
min:=a[1,j];
for i:=2 to n do
if a[i,j]<a[1,j] then
begin
min:=a[i,j];
end;
writeln ('Минимальный элемент ',j,' строки равен ',min);
end;
end.

 

 2 задача

program test;
var a: array of integer;
n,i,t,c,min,max: integer;
begin
writeln ('Введите размерность массива');
readln (n);
setlength (a,n+1);
for i:=1 to n do begin
writeln ('Введите ', i, ' элемент массива');
readln (a[i]);
end;
c:=1;
while c=1 do begin
c:=0;
for i:= 1 to n-1 do begin
if a[i]>a[i+1] then begin t:=a[i]; a[i]:=a[i+1]; a[i+1]:=t; c:=1;
end;
end; end;
for i:=1 to n do
write (a[i],' ');
writeln ();
writeln ('Наибольший элемент массива ', a[n]);
writeln();
writeln ('Наименьший элемент массива ', a[1]);
end. 

 

 

 

 

+ 0 -
Вось
11 окт. 2014 г., 18:37:33 (9 лет назад)


Program nana05_1;
uses crt;
const n=5;
var
  a:array[1..n,1..n] of real;
  i,j: integer;
  min: real;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  writeln();
  writeln('Введите массив.');
  for i:=1 to n do
    begin
      writeln(i,'-я строка:');
        for j:=1 to n do
          begin
            write(j,'-й элемент:'); readln(a[i,j]);
          end;
    end;
  clrscr;
  for i:=1 to n do
    begin
      for j:=1 to n do
        write(a[i,j]:7:2);
      writeln();
    end;
  writeln();
  writeln('Результат');
  for j:=1 to n do
    begin
      min:=a[1,j];
      for i:=1 to n do
          begin
            if min>a[i,j] then min:=a[i,j];
          end;
      writeln('Минимальный элемент столбца ',j,' равен ',min)
    end;
end.

Program nana05_2;
uses crt;
var
  a:array[1..100] of real;
  i,j,n: integer;
  temp: real;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  writeln();
  writeln('Введите размерность массива'); readln(n);
  writeln('Введите массив.');
  for i:=1 to n do
    begin
      write(i,'-й элемент:'); readln(a[i]);
    end;
  clrscr;
  for i:=1 to n do
      write(a[i]:7:2);
  writeln();
  writeln('Результат');
  for i:=1 to n-1 do
    begin
      for j:=1 to n-i do
        if a[j]>a[j+1] then
          begin
            temp:=a[j];
            a[j]:=a[j+1];
            a[j+1]:=temp;
          end;
    end;
    for i:=1 to n do
      write(a[i]:7:2);
  writeln();
  writeln('Минимальный элемент массива равен ',a[1]:7:2) ;
  writeln('Максимальный элемент массива равен ',a[n]:7:2) ;
end.

Ответить

Другие вопросы из категории

1 задача :дан одновременный массив п целых чисел . составить программу вычисления среднего арифмитичного четных чисел 2 задача : составьте программу

сокращения одновременного массива путем удаления каждого второго элемента

272 в двоичной системе счисления

Читайте также

помогите решить задачу по информатике... Племя Мумбу-Юмбу использует алфавит из букв: αβγδεδεζλμξζφψ, точки и для разделения слов используется пробел. Скол

ько информации несет свод законов племени, если в нем 12 строк и в каждой строке по 20 символов?

Помогите решить задачу на паскале, очень нужно:

Дана строка, удалить текст находящийся в скобках (вместе со скобками)

Я тут начал делать, вот только с удалением у меня ничего не получается, напишите как можно сделать

Вот как я делал:
program zd;
uses crt;
var s:string; i,l,n,t,y:integer;
begin
clrscr;
writeln('Введите строку');
readln(s);
l:=length(s);
for i:=1 to n do begin
if s[i]='(' then
t:=i; {здесь присваивал номер найденной скобки}
if s[i]=')' then
y:=i; {так же, как и выше}
delete (s,t,i); {у меня получается, что он удаляет с открывающей скобки и всё что находится вправо, а левая часть до скобки остается нетронутой}
end;
writeln('Данный результат =', s);
readln;
end.



Вы находитесь на странице вопроса "Помогите решить задачи по информатике.Очень нужно.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.