Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Очень срочно. даю 100 пунктов. Pascal ABC. Если не сдам, будет 3 за четверть(((((((((((((( Написать программу, которая

5-9 класс

сортирует массив ПО УБЫВАНИЮ и ищет в нем элемент, равный X (это число вводится с клавиатуры). Использовать двоичный поиск.

SvetlanaK24 10 февр. 2015 г., 9:12:43 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Natka35
10 февр. 2015 г., 10:52:10 (9 лет назад)

var
l, i , n, z, j,r,m, key: integer;
a: array [1..100] of integer;

begin
readln(key, n);
for i := 1 to n do
read(a[i]);
for i := 1 to n-1 do
for j := i to n do
if a[i] < a[j] then
begin
z := a[i];
a[i] := a[j];
a[j] := z
end;

l := 1;
r := n + 1;
While l < r - 1 do
begin
m := (l + r) div 2;
if a[m] < key then r := m
else l := m;
end;
if a[l] = key then WriteLn(l);
end.

Ответить

Другие вопросы из категории

помогите пожалуйста сделать
Помогите,пожалуйста, решить задачу.

В марафоне участвуют 132 спортсменов. Прохождение каждым из участников промежуточного финиша регистрируется специальным устройством,которое записывает номер участника с использованием минимально возможного количества бит,одинакового для каждого спортсмена.Определите информационный объем сообщения,записанного устройством ,после того как промежуточный финиш прошли 84 бегунов.

1.Производится бросание симметричной четырехгранной пирамидки . Какое количество информации мы получаем в зрительном сообщении о ее падении на одну из

граней ?
а)1бит
б)2бита
в)4бита
г)1байт
2.Из непрозрачного мешочка вынимают шарики с номерами , и известно , что информационное сообщение о номере шарика несет 5 битов информации . определить количество шариков в мешочке .
3.Какое количество информации пр игре в крестики-нолики на поле размером 4*4 клетки получит второй игрок после первого ходы первого игрока ?

Читайте также

1.Дано целое число N.Написать программу ,увеличивающую число в 3 раза ,если оно больше нуля

2.Дано целое число N.Написать программу ,заменяющую его нулём ,если больше или равно нулю,и увеличивающая его в 2 раза ,если число меньше нуля.
3 .Дано целые числа a и b .Написать программу , которая выводит сначала большее число ,затем меньшее.
4.Даны числа a,b,c.Написать программу ,выводящую их в возрастающем порядке.
ПЛИЗ ПОМОГИТЕ

ОЧЕНЬ СРОЧНО!!!!!!!

По каналу один за другим идут пароходы "Обь" и "Восток". Навстречу им идут один за другим пароходы "Мир" и "Енисей". Канал такой ширины, что два парохода в нем разойтись не могут. Но с одной стороны канал имеет расширение, в котором может поместиться один пароход. Как можно пароходам разойтись и продолжить свой путь?
Изобразите решение в виде схемы.ЗАРАНЕЕ СПАСИБО!(объясните,кто как может,очень срочно)

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc

2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC



Вы находитесь на странице вопроса "Очень срочно. даю 100 пунктов. Pascal ABC. Если не сдам, будет 3 за четверть(((((((((((((( Написать программу, которая", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.