Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Разработать программу в Pascal решения уравнения, использующую условный оператор. Ax^2+x+c=0 m=2, n=3

10-11 класс

Tmidov 01 дек. 2013 г., 20:57:51 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Офеличка
01 дек. 2013 г., 22:46:18 (10 лет назад)

program acxD;
uses crt;
var a,c,D:integer;
    x1,x2:real;
begin
Writeln('Vvedi a,c');
readln(a,c);
D:=1-4*a*c;
if D>0 then begin
writeln('V otvete x1,x2 :');
x1:=(1-sqrt(D))/2*a;
x2:=(1+sqrt(D))/2*a;
writeln('x1=',x1,' x2=',x2);
end;
if D=0 then begin writeln('x1=x2');
x1:=1/2*a;
writeln('x=',x1);
end;
if D<0 then writeln('V otvete pystoe mnojestvo!');
end.



+ 0 -
AngelinaPavlovna
02 дек. 2013 г., 1:46:03 (10 лет назад)

программу которая будет считать это уравнение

+ 0 -
Mashkak81
02 дек. 2013 г., 3:20:30 (10 лет назад)

при вводимом а, с?

+ 0 -
Nastysq
02 дек. 2013 г., 3:58:55 (10 лет назад)

да

+ 0 -
Cat256548572
02 дек. 2013 г., 5:40:16 (10 лет назад)

Мы в 10 классе и уже решаем функции и процедуры... Вы везучие больно)

+ 0 -
прикит
02 дек. 2013 г., 7:58:49 (10 лет назад)

я в школе бейсик прохожу.. а в учебнике задание в паскале написать

Ответить

Другие вопросы из категории

решение - объяснение Сколько существует различных пар натуральных чисел, таких что: Ваш ответ: 86 1. Оба числа, записанные в

шестеричной системе счисления, имеют ровно по три значащих разряда. 2. Сумма этих чисел, записанная в шестеричной системе счисления, содержит только цифры «1». Пары чисел, отличающиеся только порядком следования чисел в паре, считаются одинаковыми. В ответе укажите целое число.

Читайте также

Здравствуйте! Помогите пожалуйста с программой.

Описать функцию у=arcsin(x), cоставить программу решения уравнения sin(ax+b)=c (Паскаль)



Написать программу в Pascal, используя массивы.

Дано массив А[1..n]. Сделать программу которая выводит те элементы массива? индексы которых являются степени двойки
Желательно с обьяснением строк

Задание. Составьте блок схему алгоритма решения задачи и программу на языке Turbo Pascal c использованием условного оператора.

Даны три целых числа.Найти кол-во положительных чисел в исходном наборе.

От прямоугольника 324х141 отрезают квадраты со

стороной 141, пока это возможно. Затем вновь отрезают квадраты со стороной,
равной 324-2*141=42 и т.д. На какие квадраты и насколько будет разделен прямоугольник?
Решение программы в Pascal ABC



Вы находитесь на странице вопроса "Разработать программу в Pascal решения уравнения, использующую условный оператор. Ax^2+x+c=0 m=2, n=3", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.