Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Pascal.

10-11 класс

Составьте программу замены местами в массиве B(N) первого положительного и минимального элементов. Спасибо заранее

Deniska20 14 авг. 2014 г., 13:49:10 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Snemi
14 авг. 2014 г., 16:25:16 (9 лет назад)

program gt;
var b:array[1..100]of integer;
r,i,n,q,min,t:integer;
begin
read(N);
q:=0;
for i:=1 to n do
begin
read(b[i]);
if(b[i]>0)then begin
q:=q+1;
if(q=1)then begin
r:=i;
t:=b[i];
end;
end;
end;
min:=b[1];
for i:=2 to n do
if(b[i]<min)then min:=b[i];
for i:=1 to n do
begin
if(b[i]=min)then b[i]:=t;
if(i=r)then b[i]:=min;
write(b[i],' ');
end;
end.

Ответить

Другие вопросы из категории

Вася уехал на отпуск в Японию. По возвращению он понял что забыл пароль от архива.

Но он точно помнит что пароль состоит и 4 символов. Так же он помнит что в пароле присутсвуют цифры от 1 до 9 и буквы латинского алфавита от A до Z. У Васи есть программа для подстановки, но ей нужны база паролей.Помогите Васе написать программу, для базы паролей

Решите кроссворд.

Единица измерения количества информации.(3 буквы)
Одна из тригонометрических функций.(5 букв)
Один из первых языков программирования высокого уровня(7 букв)
Операнд операции сложения.( 9 букв)
Язык программирования (7 букв)
Совокупность точек графического изображения на этапе монитора.(5 букв)
Жаргонное название микросхемы.(3 буквы)

Создайте

программу, которая
"спрашивает" имя, а
затем, используя это имя, приветствует
программиста.

Читайте также

Напишите на языках Pascal и C++ программу, которая генерирует 2 случайных вещественных числа и вычисляет их сумму, разность, произведение и

частное. Напишите на языках Pascal и C++ программу, моделирующую выбор одной из костей домино ( в наборе 28 костей домино, каждая состоит из двух половин, на каждой половине – от 0 до 6 очков). С помощью этой программы ответьте на вопрос: какова вероятность того, что выпадет кость с числом очков, кратным 3

В языке Pascal есть функция Pandom (a), которая служит для получения случайного ряда чисел из интервала (0;а). Вопрос: придумать, как можно при помощи

формул языка Pascal сделать так, чтобы случайные числа выпадали в интервале (a;b)

Скажите по конкретнее, что нужно знать чтобы научиться программировать в Pascal - что именно нужно изучить...

У нас на первом курсе тема Pascal, а я гляжу на него как баран на новые ворота...
Я отстал сильно на 2 недели и ни могу ни как понять его... Скажите пожалуйста по конкретнее с чего начать, что именно нужно изучить или выучить, понять, чтобы знать как составлять на нём программы ?

ЗАДАЧА ДЛЯ PASCAL ABC: В группе 30 учеников. За выполненный тест они могут

получить от 5 до 15 баллов (Сгенерить случайные числа

Помогите, пожалуйста, решить задачу:

Дан вектор из 25 элементов. Найти минимальное значение. Записать на языке Pascal и построить алгоритм.



Вы находитесь на странице вопроса "Pascal.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.