Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Составить программу, читающую положительные значения x,y,z и печатающую одно из слов: нельзя, остроугольный, прямоугольный, тупоугольный в зависимости от

5-9 класс

того, какой треугольник можно построить из отрезков с длинами x,y,z

Kostarika1000 18 окт. 2014 г., 3:44:47 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nelli777300
18 окт. 2014 г., 5:22:48 (9 лет назад)

Решение на C: 

 

#include <stdio.h>

int main()
{
int a, b, c, buf;
scanf("%d %d %d", &a, &b, &c);
if (a<b) {buf=a; a=b; b=buf;};
if (a<c) {buf=a; a=c; c=buf;};

if (a>=(b+c)) printf("не существует\n");
else
 if (a*a > (b*b + c*c)) printf("тупоугольгый\n");
else
 if (a*a == (b*b + c*c)) printf("прямоугольный\n");
 else printf("остроугольный\n");
}

Ответить

Другие вопросы из категории

Первым программистом в истории человечества (из заслуг-введения понятий "цикл" и "рабочая ячейка" считается...

А)Ада Августа Лавлейс
Б)Блез Паскаль
В)Алан Тьюринг
Г)Чарльз Беббидж
Помогите пожалуйста!

Помогите пожалуйста

Заранее спасибо

Помогите по инфе: Злая мачеха отправила падчерицу к роднику за водой."Вот тебе 2ведра, в одно из них входит 9литров воды, а в другое-5 литров.Но ты

должна принести домой ровно 3 литра воды",-сказала она бедной девушке.Как должна действовать падчерица, чтобы выполнить это поручение?

ПОМОГИТЕ ПОЖАЛУЙСТА ВОПРОСЫ!!!

С 3-4!!!!!

Читайте также

составьте программу которая запрашивает значения элементов одномерного числового массива а, стоящего из 10 элементов,формирует и выводит на экран в

строку данный массив. Найти сумму неположительных элементов массива,количество элементов кратных 3, произведение элементов,стоящих на четных местах

Даны действительные числа x, y. Если x и y отрицательны, то каждое значение заменить модулем; если отрицательно только одно из них, то оба значения

увеличить на 0,5; если оба значения неотрицательны и ни одно из них не пренадлежит отрезку [0.5;2,0], то оба значения уменьшить в 10 раз ; в остальных случаях x и y остаются без изменения . Помогите , завтра зачет.

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

A) Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму элементов с четными значениями

и количество элементов с нечетными значениями.

б) Составьте программу, которая заполняет массив b[1..8] случайными целыми числами в диапазоне от 1 до 10 и находит произведение элементов с нечетными значениями и количество элементов с четными значениями.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.



Вы находитесь на странице вопроса "Составить программу, читающую положительные значения x,y,z и печатающую одно из слов: нельзя, остроугольный, прямоугольный, тупоугольный в зависимости от", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.