Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

помогите пожалуйста с информатикой, очень нужно...)

10-11 класс

Дан текст. Слова в тексте разделены одним или несколькими пробелами. Написать программу, выводящую все слова в алфавитном порядке.

Ferr 04 янв. 2016 г., 21:14:10 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kafa1
04 янв. 2016 г., 22:38:09 (8 лет назад)



var
s,s1:string;   
a:array[1..100] of string;   
 n,i,j,k:byte;
begin
writeln('Введите текст из слов, разделенных пробелами');
readln(s);
s:=' '+s+' ';
n:=length(s);
i:=2;k:=0;while i<=n do
if (s[i]<>' ')and (s[i-1]=' ') then
begin  k:=k+1;
  j:=i; 
s1:=''; 
 while (j<=n) and (s[j]<>' ') do
   begin 
  s1:=s1+s[j]; 
  j:=j+1;   
end; 
a[k]:=s1;
 i:=i+length(s1);
 end
else i:=i+1;
for i:=1 to k-1 do
for j:=i+1 to k do
if a[i]>a[j] then 
begin  s1:=a[i]; 
 a[i]:=a[j];
  a[j]:=s1
 end;
writeln('Слова текста в алфавитном порядке:');
for i:=1 to k do
writeln(a[i]);
end.

+ 0 -
Barbivlada01
05 янв. 2016 г., 1:12:26 (8 лет назад)

Какой язык программирования и какая версия компилятора?

+ 0 -
Gela2000
05 янв. 2016 г., 3:18:57 (8 лет назад)

без понятия, если честно. Pascal ABC - это всё,что могу сказать...(

+ 0 -
Саня96
05 янв. 2016 г., 5:00:19 (8 лет назад)

На каком языке написаны слова?

+ 0 -
Tatianed
05 янв. 2016 г., 7:52:36 (8 лет назад)

на русском

Ответить

Другие вопросы из категории

Пожалуйста очень надо,прошу 315,15 (десятичной) перевести в (восьмеричную)систему счисления, 412(в пятой) перевести в (десятичную), 1201(в третьей)

перевести в (десятичную), АЕ(шестнадцатой) перевести в (десятичную) Спасибо,спасибо,спасибо

Читайте также

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста!

Дано 20 чисел. Посчитать количество чисел равных 0.
Очень нужно! и срочно...



Вы находитесь на странице вопроса "помогите пожалуйста с информатикой, очень нужно...)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.