Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Program P1;

10-11 класс

{ Лабораторная работа №2}
uses crt;
var
x : real;
y : real;
begin
clrscr;
write('Введите x: ');
readln(x);
write('Введите y: ');
readln(y);
if (y<=sqrt(9-(sqr(x+3)))) and (x>=-3) and (y>=0) and (x<=0) and (y<=3)or (y>=-sqrt(9-(sqr(x+3)))) and (x<=3) and (y<=0) and (x>=0) and (y>=-3)then
writeln('Значение принадлежит области функции');
else
writeln('Значение не принадлежит области функции');
readkey;
end.

Abusa 15 янв. 2016 г., 11:22:57 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Granatik555
15 янв. 2016 г., 13:44:55 (8 лет назад)

Нет. Зачем оператор? Else ─ иначе.

Ответить

Другие вопросы из категории

помогите пожалуйста с информатикой, очень нужно...)

Дан текст. Слова в тексте разделены одним или несколькими пробелами. Написать программу, выводящую все слова в алфавитном порядке.

Пожалуйста очень надо,прошу 315,15 (десятичной) перевести в (восьмеричную)систему счисления, 412(в пятой) перевести в (десятичную), 1201(в третьей)

перевести в (десятичную), АЕ(шестнадцатой) перевести в (десятичную) Спасибо,спасибо,спасибо

Читайте также

Что выведет данная программа? program p1;

var Z:integer;
function f (n:byte):longint;
begin
if n=0 then f:=1
else f:=(2*n)*f(n-1); end;
begin
z:=f(5); writeln (z);end.

В непозиционной системе счисления, которая называется системой остатков (СО), в качестве оснований выбираются взаимно простые числа, например, p1=3,

p2=5, p3=7. При этом диапазон однозначного представления чисел равен произведению оснований (в приведенном примере p1∙p2∙p3 = 105, т. е. однозначно представляются все числа от 0 до 104). Любое число в этом диапазоне записывается остатками от целочисленного деления этого числа на выбранные основания. Например, число A = 19 запишется в СО с основаниями 3, 5, 7 так: A = (1, 4, 5). Укажите, какая из записей соответствует числу 5, записанному в системе остатков с основаниями 3, 5, 7.
1) (3, 0, 2) 2) (2, 0, 2) 3) (2, 0, 5) 4) (5, 5, 5)

Если в прямоугольной матрице меньше половины столбцов содержит отрицательные элементы, то все элементы с нечетными номерами столбцов умножить на 10. В

противном случае все отрицательные элементы матрицы возвести в квадрат.

У меня получилось вот что:

program s455;
uses crt;
const
m=10;
n=12;
Var
A: array[1..m,1..n] of integer;
i, j, k, s: integer;

Begin
writeln('Enter size');
readln;
s:=0;
for j:=1 to m do
begin
k:=0;
for i:=1 to n do
end;
begin
if a<0 then begin
k:=1;
end;
if k=1 then s:=s+1;
end;
begin;
if k<0
then a[i, j]:=a[i, j*2-1]*10;
else a[i, j]:=a[i, j]*c [i, j]
end;
writeln

Не могу понять в чем ошибка

program klass; type ocenki=record name:string[15]; marks: array [1..5] of integer; end; var a,k,i:integer;

c:array [1..5] of ocenki;

begin k:=0;

For i:=1 to 5 do

With c[i] do

begin

write('vvedite name'); readln(name);

write('vvedine marks');

for i:=1 to 5 do read(marks[i]);

a:=i;

if c[a].marks < 2 (вот здесь выдает что операнды имеют неприводимые типы) then k:=k+1; writeln(k);

end;

end.

(Подскажите пожалуйста где допустила ошибку)



Вы находитесь на странице вопроса "Program P1;", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.