Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Составить алгоритм

10-11 класс

вычисления значения суммы членов
бесконечного ряда методом итераций s = 1 +

Raida040283 21 нояб. 2016 г., 4:16:29 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vikusya260702Викуся
21 нояб. 2016 г., 5:23:25 (7 лет назад)

const
  x = 0.75;
  eps = 0.5e-3;

var
  s, y1, y2, n, sgn, x2, prevf: real;

begin
  {для второго члена последовательности}
  x2 := sqr(x);
  prevf := 2;
  y1 := 1;        {первый член последовательности}
  y2 := x2 / prevf; {второй член последовательности}
  s := y1;        {накопленная сумма ряда}
  n := 1;         {последний член последовательности в сумме}
  sgn := 1;       {знак очередного члена ряда}
  while abs(y1 - y2) >= eps do
  begin
    s := s + y2;  {продолжаем накопление}
    n := n + 1;
    y1 := y2;
    x2 := x2 * sqr(x);
    prevf := prevf * (2 * n - 1) * 2 * n;
    sgn := -sgn;
    y2 := sgn * (2 * n - 1) * x2 / prevf
  end;
  writeln('Сумма ряда из ',n, ' членов равна ', s)
end.

Тестовое решение:

Сумма ряда из 5 членов равна 1.24291779994965


+ 0 -
ZVEIN
21 нояб. 2016 г., 6:22:59 (7 лет назад)

Комментарий удален

+ 0 -
222368
21 нояб. 2016 г., 8:32:12 (7 лет назад)

Недавно с одним очень знающим (без кавычек) человеком на эту тему тоже говорили, по поводу составления запросов в Акцессе. Естественно, он такое не воспринимал всерьез и говорил, что только в SQL можно создать сложный запрос. Предложил мне создать в Акцессе запрос (наверно, сложный в формате SQL), а получилось так, что я его создал с помощью одной только мыши, не набирая даже не одного символа на клаве)))

+ 0 -
Alidead
21 нояб. 2016 г., 10:42:47 (7 лет назад)

Конечно, это скорее всего, исключение, но все-же!)))

+ 0 -
68itazaq
21 нояб. 2016 г., 12:26:18 (7 лет назад)

Комментарий удален

+ 0 -
89161151581
21 нояб. 2016 г., 15:12:15 (7 лет назад)

Естественно! Поэтому меня и злит, когда начинают навешивать ярлыки. И когда говорят, что "самый лучший - это... ". Нет универсального инструмента. А если и есть, то работа с ним будет не самая эффективная.

Ответить

Другие вопросы из категории

Составить программу начисления стипендии группе студентов из 25 человек

по итогам сессии из 5 экзаменов. Стипендия в размере 900 рублей
начисляется студенту, не имеющему троек. Посчитать сумму, необходимую
для выплаты стипендии и вывести список студентов, получающий стипендию.

Подскажите, пожалуйста решение на задачу Паскаль по информатике. даны натуральные числа от 1 до 50. Найдите сумму тех, которые делятся на 5 и на

7.Решите пожалуйста цикл с предусловием и с постусловием, блок схемы и программы.

Читайте также

Помогите составить алгоритм!

Составьте алгоритм(в паскале\на алгоритмическом языке), в котором вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних месяцев, осенних месяцев.

1. Составьте алгоритм вычисления суммы квадратов цифр,заданного трехзначного числа.

2.Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа.
3. Для заданного действительного числа К вычислить значение произведения
(99/k^3-98)*(97/k^3+96)*(95/k^3-94)*...*(3/k^3+2)

1. Составить описание ( алгоритм ) создания архива данных.

Извлечение данных из архива
2. Составить алгоритм записи информации на компакт-диски различных видов.
Организация информации на компакт-диске с интерактивным меню.

Ребята,срочно помогите!)Даю 100 баллов.Составить алгоритм решения задачи на языке C++ . В отчете предоставить три программы с разными операторами

цикла (do ...while, while, for). В алгоритме и программе массивов не использовать.

Я здесь набросал все ,что мог, помогите доработать, написать до конца все эти операторы в одну программу,не получается.

#include <iostream>
#include <cstdlib>
#include <conio.h>
#include <math.h>

using namespace std;
int main()
{
float a,z,xn,xk,dx,R,max,min; float count=0,x;
a = 2.94;xn = 1.5;xk = 5.5;dx = 0.4;
while (xn <= xk)

for (x >= xn; x <= xk; x+=dx, dx = dx + 0.4)
{
do
{
z = a*pow((a*x*x*x*x*x*x*x/cos(a*a*a)+1,31),(1/5));
printf("X = %10f, Z = %10f \n", x, z);
dx = dx + 0.4;
}
while (x <= xk);
return 0;
}
{
max = x;min = z;
if (x > max) max = x;
if (z < max) min = z;
if (count > 2) count = 0;
if (count == 2) printf("X = %10f, Z = %10f \n", x, z);
count=0;
}
cout<<"max="<<max<<"\t min="<<min<<"\n";
cout<<"R="<<min-max<<"\n";
system("PAUSE");
return 0;
}

1. Линейный алгоритм.



Составить алгоритм вычисления
площади поверхности цилиндра S= 2*π*r(h+r).






Вы находитесь на странице вопроса "Составить алгоритм", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.