. Составьте программу (полный текст программы) для решения следующей задачи. Введите с клавиатуры три числа: А, В, С. Если все они четные, то найдите и
5-9 класс
|
выведите на экран их сумму. Если все они нечетные и A>B>C, то определите и выведите значения наибольшего и наименьшего из чисел. Иначе, выведите числа без изменения. Фрагмент программы: if (a mod 2 = 0) and (b mod 2 = 0) and (c mod 2 = 0) then begin S:=a+b+c; writeln('сумма равна ', S); end; if (a mod 2 <> 0) and (b mod 2 <> 0) and (c mod 2 <> 0) and (a>b) and (b>c) then begin writeln('наибольшее число ', A); writeln('наименьшее число ', C); end else writeln('a= ',a,' b= ', b, ' c= ',c);


var
a,b,c,s:integer;
begin
readln(a,b,c);
if (a mod 2 = 0) and (b mod 2 = 0) and (c mod 2 = 0) then
Другие вопросы из категории
Читайте также
пунктирными линиями. Очень нужно, благодарю))
Построй
блок-схему или напиши программу на языке Паскаль для решения следующей задачи:
1)вычисление стоимости покупок в магазине;
2)вычисление суммы сдачи от данных вами продавцу денег;
3)определение времени показа по телевизору интересующего вас фильма;
4)вычисление площади треугольника;
5)определение времени падения кирпича с крыши дома;
6)определение месячной платы за расход электроэнергии;
7)перевод русского текста на итальянский язык;
8)перевод итальянского текста на русский язык.
стоимости покупок в магазине 4)Приготовлени салата по рецепту 5)Выполнение домашнего задания
в 5% - если сумма больше 1000 руб. Фрагмент программы: if x>500 then y:=0.97*x; if x>1000 then y:=0.95*x;