Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

5-9 класс

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

Irka076 19 марта 2015 г., 12:53:14 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sergey12345654321
19 марта 2015 г., 15:45:55 (9 лет назад)

1.const  N=10;
type Vector = array [1..N] of integer;
var B: vector;   
     max :integer;
procedure IntVector(N: integer; var a: vector);
begin 
 for var i := 1 to N do  a[i] := random(100);
end;
procedure OutVector(N: integer; a: vector);
begin  for var i := 1 to N do  
begin      write(a[i]:5);
end;
end;
procedure Srav (a:vector; N,g:integer);
begin
g := a[1];
for var i:=1 to N do
if (g < a[i]) then g:=a[i];
writeln (g);
end;
Begin 
IntVector(N, B); 
writeln; 
OutVector(N, B ); 
writeln;  
Srav(B,N, max); 
writeln;
End.
2. 

+ 0 -
DashaMal1234
19 марта 2015 г., 18:06:22 (9 лет назад)

1)
constn=10;
var
i:byte;
max:real;
a:array[1..n] of real;
begin
for i:=1 to n do
a[i]:=random(100);
for i:=1 to n do
write(a[i]:3);
for i:=1 to n do
 max:=a[i];
if max<a[i] then max:=a[i];
writeln('Максимальный элемент = ',max);
end.

Ответить

Другие вопросы из категории

Для кодирования секретного сообщения используются 12 специальных значков-символов. При этом символы кодируются одним и тем же минимально возможным

количеством бит. Чему равен информационный объем сообщения длинной в 256 символов ?

Когда объект можно назвать системой? Приведите примеры систем.

10. Можно ли назвать объект «ножницы» системой? Обоснуйте свой ответ.

Составьте задачу на подобии такой и решите ее:

текст составлен с использованием алфавита мощностью 64 символа и содержит 100 символов. каков информационный объем текста
Помогите, пожалуйста. Я нуб в информатике

Все 4-буквенные слова, составленные из букв С, Л, О, Н записаны в алфавитном порядке и пронумерованы.

Вот начало списка:
1. ЛЛЛЛ
2. ЛЛЛН
3. ЛЛЛО
4. ЛЛЛС
5. ЛЛНЛ
Запишите слово, которое стоит под номером 250.

Примечание: для всех слов, длина которых будет больше полученной комбинации в нужной системе счисления, впереди добавлять незначащие нули и заменять их в ответе на соответствующие нулям буквы. ПОМОГИТЕ ПОЖАЛУЙСТА

Читайте также

Одномерный массив из 10 элементов с номерами от 10 до 20 заполнить случайным образом числами от 0 до 22. Все элементы массива,значения которых лежат между

10 и 20 включительно,увеличить в 5 раз.Вывести на экран монитора первоначальный и преобразованный массивы в столбик.

Решить задачи на языке программирования в Turbo Pascal: 1) Дан массив, состоящий из 10 чисел, значения могут быть

от -100 до 100. Определить минимальное положительное число.

2) Дан массив, состоящий из 10 чисел. Найдите номера тех элементовв масива, которые наименее различаются.

Одномерный массив из 15 элементов заполнить случайным образом числами от 7 до 12. Присвоить 8-му элементу значение 10-го элемента, увеличенное а 5, а

10-му элементу присвоить значение 13. Вывести на экран монитора первоначальный и преобразованный массивы в строчку.

Одномерный массив из 7 элементов заполнить случайным образом числами от 1 до 15.Преобразовать массив таким образом,чтобы каждому элементу присваивалось

значение предыдущего,при этом первому элементу должно присвоиться значение последнего элемента таблицы. Вывести на экран монитора первоначальный и преобразованный массивы в столбик(столбики должны быть расположены рядом).

Школьный уровень 1.Найти все элементы массива b(n),большие или равные 0.На экран вывести номер элементо

в,их значения и количество.

2.В одномерном массиве целых чисел,содержащем 20 элементов,удалить k-ый элемент массива.Массив заполняется случайным образом числами от 0 до 50.



Вы находитесь на странице вопроса "1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.