Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

2 задачи по программированию: 1) Три точки заданы своими координатами (x1,y1),

5-9 класс

(x2,y2), (x3,y3). Напишите программу, позволяющую выяснить, какие из них находятся на максимальном расстоянии друг от друга, и вывести на печать значение этого расстояния. Вычисление расстояния между двумя точками оформите в виде процедуры.

2) Даны действительные числа Х и Y. Напишите программу, позволяющую вычислить значение следующего выражения:

Z=(signX + signY)*sign(X+Y),

Starikovaagata 16 окт. 2014 г., 5:52:16 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Snh84mud
16 окт. 2014 г., 6:32:14 (9 лет назад)

program cgt;
var x1,y1,x2,a,y2,b,c,x3,y3:real;
procedure IOI(x1,y1,x2,y2:real;var a:real);
begin
a:=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
end;
begin
read(x1,x2,y1,y2,x3,y3);
IOI(x1,y1,x2,y2,a);
IOI(x1,y1,x3,y3,b);
IOI(x3,y3,x2,y2,c);
if(a>=b)and(a>=c)then writeln('первая и вторая точка ',a) else
if(b>=a)and(b>=c)then writeln('первая и третая точка ',b) else
if(c>=b)and(c>=a)then writeln('третая и вторая точка ',c);
end.
2)
program cgt;
var z,x,y:real;function IOI(x:real):real;
begin
if(x=0)then IOI:=0;
if(x<0)then IOI:=-1;
if(x>0)then IOI:=1;
end;
begin
read(x,y);
z:=(IOI(x)+IOI(Y))*IOI(x+y);
writeln(z);
end.

Ответить

Другие вопросы из категории

Информационный объём статьи 48 Кбайт. Сколько страниц займёт статья, если на одной странице электронного документа помещается 64 строки по 64 символа,

а каждый символ представлен кодировке в KOI-8 (в кодировке KOI-8 каждый символ занимает 8 бит памяти

У ис­пол­ни­те­ля Каль­ку­ля­тор две ко­ман­ды, ко­то­рым при­сво­е­ны но­ме­ра:

1. при­бавь 3
2. раздели на 2
Первая прибавляет к числу на экране 3, вторая делит число на экране на 2.
Алгоритм работает только с натуральными числами.

Составе алгоритм получения из числа 23 число 4.
1) 111222
2)11112
3)12122
4) 12121

P.S желательно с решением

Читайте также

ПОМОГИТЕ РЕШИТЬ ЗАДАЧУ.

Составить алгоритм для решения задачи: Определить, какая из двух точек заданных своими координатами расположена ближе к началу координат.

Вычислите расстояние между двумя точками с данными координатами: (x1,y1) и (x2,y2)

Формула для нахождения расстояния: картинка снизу
И всё это в паскаль. Спасибо.



Вы находитесь на странице вопроса "2 задачи по программированию: 1) Три точки заданы своими координатами (x1,y1),", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.