Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дано арифметическое выражение Y=(b – x)3+b2. Найти значение Y при любых значениях b и х.

5-9 класс

Вывести на экран введенные b и х, и результат Y в одной строке
Y=… b=… х=…

Nozdracheva199 31 марта 2015 г., 20:53:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ддаарёнка
31 марта 2015 г., 23:34:49 (9 лет назад)

program vir;

var

 y,b,x:real;

Begin

  writeln('Введите переменные b и х для уравнения y=(b-x)3+b2');

  readln(b,x);

  y:=(b-x)*3+b*2;

  writeln('Y= ',y:6:3,'  b= ',b:6:3,'  x= ',6:3);

  readln;

End.

Ответить

Читайте также

1) Как вы думаете, можно ли использовать в арифметическом выражении оператора присваивания неопределенную переменную? К каким последствиям это может

привести?

2) Напишите на АЯ алгоритм сложения двух простых дробей(без сокращения дроби)

3) Напишите на АЯ алгоритм вычисления Y по формуле: y=(1-x2+5x^4)^2, где x- заданное целое число. Учтите следующие ограничения: 1) В арифметических выражениях можно использовать только операции сложения, вычитания и умножения. 2) Выражение может содержать только одну арифметическую операцию. выполните трассировку алгоритма при x=2.

4) Пользуясь ограничениями предыдущей задачи, напишите наиболее короткие алгоритмы вычисления выражений: y=x^8, y=x^10, y=x^15, y=x^19. Выполните трассировку алгоритмов.

5) Запишите алгоритм циклического обмена значениями трех переменных A,B,C. Схема циклического обмена:

a-->b-->c(стрелочка C к A сверху)

Например, если до обмена было: A=1,B=2,C=3, то после обмена должно стать: A=3,B=1,C=2. Выполните трассировку.

Решите на паскаль плз

Задание 1. «Строки»



Дано
арифметическое выражение, требуется вывести его корректность.



Корректность =
true если
скобки расставлены в нем верно, = false если неверно. На корректность
влияют только скобки.

1) Дано логическое выражение, зависящее от 6 логических переменных: X1 v

¬X2 v X3 v ¬X4 v X5 v X6

Сколько существует различных наборов значений переменных, при которых выражение истинно?

1) 1 2) 2 3) 63 4) 64

напишите на АЯ алгоритм вычисления y по формуле ,где x-заданное число.Учтите следующие ограничения:1)в арифметических выражениях можно использовать только

опереции сложения,вычитания,и умножения;2)каждое выражение может содержать только одну арифметическую операцию.Выполните трассировку алгоритма при x=2



Вы находитесь на странице вопроса "Дано арифметическое выражение Y=(b – x)3+b2. Найти значение Y при любых значениях b и х.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.