Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Помогите пожалуйста составить алгоритм и решить его что ли! Задан одномерный массив из n элементов. Найдите среднее арифметическое всех этих элементов.

10-11 класс

Andryushevic 27 марта 2016 г., 23:49:53 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
89068038645
28 марта 2016 г., 1:50:33 (8 лет назад)

program chik;
var n,i,s:integer;
h:real;
a:array[1..10000]of integer;
begin
read(n);s:=0;
for i:=1 to n do
begin
read(a[i]);
s:=s+a[i];
end;
h:=s/h;
writeln(h);
end.
n-количество чисел
s-сумма чисел

Ответить

Другие вопросы из категории

Напишите свое "Пятое поколение ЭВМ"
в течение 3 минут производилапсь четрехканальная звукозапись с частотой дискретизации 16 КГц и 32-битным разрешением. Сжатие данных не производилось.

Какая из приведенных ниже величин наиболее близка к размеру полученного файла? 20 Мб, 30 Мб, 40 Мб, 60 Мб

Читайте также

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

помогите пожалуйста.....................................в течении получаса. дан целочисленный массив из 30 элементов. элементы массива могут

принимать значения от 0 до 1000.описать на русском или на одном из языков програмирования алгоритм,который находит и выводит среднее арифметическое всех элементов массива,имеющих нечетное значение

ПОМОГИТЕ ПОЖАЛУЙСТА!!!

Составить программу. Создать массив из 10 элементов случайным образом, найти сумму нечетных чисел.

ЛЮДИ, ПОМОГИТЕ, ПОЖАЛУЙСТА Сформировать одномерный массив из 20 элементов (значения элементов задаются случайным образом). Вывести массива на

экран. Найти среднее арифметическое элементов первой половины массива и сумму элементов второй половины массива.

паскаль массивы



Вы находитесь на странице вопроса "Помогите пожалуйста составить алгоритм и решить его что ли! Задан одномерный массив из n элементов. Найдите среднее арифметическое всех этих элементов.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.