Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

В Турбо паскале Уже нужно

10-11 класс

Составить программу для обработки массива содержащего 10 целых числе. Определить максимальный элемент массива. Выполнение каждого логического блока программы оформить в виде отдельных процедур

LenChiKsA 20 апр. 2013 г., 21:32:54 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Galinamalceva
21 апр. 2013 г., 0:07:46 (10 лет назад)

uses crt;
var i,j,k,n,max:integer; a:array[1..100] of integer;
procedure rmassr;
begin
    for i:=1 to n do
    a[i]:=random(10);
end;
procedure rmassy;
begin
    for i:=1 to n do
    readln(a[i]);
end;
procedure maxe;
begin
max:=a[1];
    for i:=2 to n do begin
        if a[i] > max then max:=a[i];
    end;
    writeln('max element = ', max);
end;
procedure wmass;
begin
    for i:=1 to n do
    write(a[i],' ');
    writeln;
end;
begin
clrscr;
randomize;
write('Длина массива'); readln(n);
write('1-random; 2- в ручную '); readln(k);
if k=1 then rmassr()
else rmassy();
wmass();
maxe();
readln
end.

Ответить

Другие вопросы из категории

перевести в 10 сс

а)1001110²(двойка снизу)
б)57(8) маленькая
в)12С(16) маленькие
перевести из 10 сс
а) в 8сс-428(10)
б) в2 сс-244(10)

1) скорость передачи данных от источника А по радиоканалу связи 2∧12 байт\с.После получения первых 4∧9 бит данных началась их ретрансляция по другому

каналу в приемник B со средней скоростью 8кбайт\с .За какое время( в секундах) данные объемом 2∧7 кбайт из А полностью поступит в В.

Читайте также

Решать задачу нужно на древнем ТП7 (Турбо паскаль).

Вычислить сумму элементов каждой строки, вводимого С КЛАВИАТУРЫ ДВУМЕРНОГО массива. Обязательно с клавиатуры. Напишите программу пожалуйста.

СРОЧНО!!! Помогите пожалуйста с турбо паскаль, задание на тему циклы....

Как мне препод объясняла там должно быть for i:=1 to N do begin
P:P*(2*i)/(2*i+1)
end;
Вот часть которую нужно как то применить к этому заданию...
Как будет выглядеть весь код?)))

помогите, ПОЖАЛУЙСТА! СРОЧНО!!!задача по турбо паскаль. Определить сколько метров сетки нужно, чтобы загородить большой сад почти прямоугольной

формы со сторонами a, b, и сколько удобрений (d) надо купить, если на 1 м2 требуется с кг? (р = 2(а+b), d = abc)

Срочно! Помогите пожалуста! Нужно написать програмный код в турбо паскале! Заранее ОГРОМНОЕ СПАСИБО!! Заполнить массив из 10 элементов

случайными числами в интервале от 0 до 4 и вывести номера всех элементов, равных X.

Пример:

Исходный массив:

4 0 1 2 0 1 3 4 1 0

Что ищем? 0

A[2], A[5], A[10]



Вы находитесь на странице вопроса "В Турбо паскале Уже нужно", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.