Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Решите пожалуйста! 1. С клавиатуры вводятся числа, пока не будет введено число, делящееся на 5. Подсчитать количество и сумму тех, которые

5-9 класс

больше 10.
2. Напечатать все делители заданного числа.

Это циклы,ршите в паскале!

Starfordg 19 апр. 2014 г., 13:54:16 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Анютик2002лала
19 апр. 2014 г., 16:02:33 (10 лет назад)

var

  a, n, s, i: integer;  //n - количество, s - сумма, a - вводимое число

 

begin

  a:= 1;

  while a mod 5 <> 0 do

  begin

    writeln('Введите целое число');

    readln(a);

    if a > 10 then

    begin

      inc(n);  //Увеличиваем счетчик на 1

      s:= s + a;

    end;

  end;

  writeln('Количество чисел, больших 10:  ', n, ', сумма чисел, больших 10:  ', s);

  write('Делители числа ', a, ':  ');

  for i:= 2 to a do

    if a mod i = 0 then write(i, '  ');

end.

Ответить

Другие вопросы из категории

В каких позиционных системах счисления выполняется равенство 515b+4305=9463. Цифры со значением больше 9 представляются строчными латинскими буквами.

Таким образом, основание системы счисления должно быть больше 2 и не больше 36.
В ответе перечислите все основания систем счисления в порядке их возрастания, разделяя их запятой.

Читайте также

"сколько лет бабушке?"Компьютер загадывает целое число от 1 до 100. Пользователь вводит с клавиатуры некоторое число и получает один из ответов:"Мое

чило меньше","Мое число больше","Вы угадали".процесс повторяется до тех пор пока не будет угадано число.

помогите на паскале сделать

Паскаль, помогите!!!

Дан фрагмент программы, который решает задачу поиска номера последней минимальной цифры в записи десятичного целого числа (считается, что цифры в числе пронумерованы справа налево) и выводит ее на экран. Определите, какой оператор необходимо вставить вместо троеточия ( . . . ), чтобы правильный результат выдавался для любого целого числа N. Все используемые переменные имеют целый тип данных. Ответ записывайте без пробелов.
на языке Паскаль
readln(N);
MC:=9; I:=0; K:=1; N:=abs(N);
while N< >0 do
begin
С:=N mod 10; N:=N div 10;
I:=I+1;
if ... then
begin
MC:=C; K:=I;
end;
end;
writeln(K); .
10 минут осталось, подалуйста.

ПОМОГИТЕ В ЧЕМ ОШИБКА!!

program ZADACHA1;

var
a,b,c,d,d1,e:integer;
x,y,k,l:real;

begin
WRITELN('Цыбулак Максим');
READLN(a);
READLN(b);
c:=a+b;
e:=a*b;
d:=a-b;
k:=a/b;
d1:=b-a;
l:=b/a;
WRITELN('a+b=',c);
WRITELN('a-b=',d);
WRITELN('b-a=',d1);
WRITELN('a*b=',e);
WRITELN('a/b=',k);
WRITELN('b/a=',l);
m;=SQR(a);
n;=SQR(b);
o;=SQRT(a);
p;=SQRT(b);
WRITELN('квадрат числа',a,'=',m);
WRITELN('квадрат числа',b,'=',n);
WRITELN('корень числа',a,'=',o);
WRITELN('корень числа',b,'=',p);
end.

с клавиатуры вводится число х. если

с клавиатуры вводится число х. если остаток от деления х на 6 равен 2, то значение f(x)=4*x^2 если остаток от деления х на 6 равен 3, то значение f(x) = корень из х , если остаток от деления на 6 =0 то f(x) = x.


Написать программу в паскале используя операторы if и else . Нарисовать блок схему

1.С клавиатуры вводится действительное число a.Найти его квадратный корень.

2.С клавиатуры вводится действительное число p.Записать отдельно его целую часть C.
Помогите составить программу.



Вы находитесь на странице вопроса "Решите пожалуйста! 1. С клавиатуры вводятся числа, пока не будет введено число, делящееся на 5. Подсчитать количество и сумму тех, которые", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.