Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Задано двухзначное число.Составить программу нахождениясамо малой цыфры числа

5-9 класс

Еленыыч 03 сент. 2016 г., 11:42:41 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
LisaKHR
03 сент. 2016 г., 14:25:43 (7 лет назад)

var
a: integer;

begin
readln(a);
if (a mod 10) > (a div 10) then write(a div 10) else write(a mod 10);
end.

Если нужна ещё какая-то помощь, пиши в ЛС.

Ответить

Читайте также

Помогите пожалуйста решить задания:

1) Преобразуйте двоичное число в восьмеричное:1010100
2)Преобразуйте двоичное число в десятичное:100010
3)Преобразуйте двоичное число в шестнадцатеричное:1110001000
4)Преобразуйте восьмеричное число в двоичное:67
5)Преобразуйте восьмеричное число в десятичное:207
6)Преобразуйте восьмеричное число в шестнадцатеричное: 2246
7)Преобразуйте десятичное число в двоичное:404
8)Преобразуйте десятичное число в восьмеричное:283
9)Преобразуйте десятичное число в шестнадцатеричное:1001
10)Преобразуйте шестнадцатеричное число в двоичное:5D
11)Преобразуйте шестнадцатеричное число в восьмеричное:4C
12)Преобразуйте шестнадцатеричное число в десятичное: 35B

1.Дано целое число составить программу которая определяет оканчивающие данное число цифрой семь.

2.Дано 2х значное число составить программу с помощью которой можно отпределить входит ли в это число цифра шесть.

1.Составьте программу, выводящую на экран все двухзначные числа, у которых сумма цифр равна 8.

2.Составьте программу вычисления количества трёхзначных чисел палиндромов ( чисел, которые читаются одинаково слева направо и справа налево).
3.Найти двухзначные числа, которые делятся на сумму своих цифр
4.Составьте программу вывода количества трёхзначных чисел, у которых цифры упорядочены строго по убыванию.
РЕБЯТА СРОЧНО!!!!!!!!!!!

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.



Вы находитесь на странице вопроса "Задано двухзначное число.Составить программу нахождениясамо малой цыфры числа", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.