Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Дана матрица размера M × N и целые числа K1 и K2 (1 ≤ K1 < K2 ≤ M).

10-11 класс

Поменять местами строки матрицы с номерами K1 и K2.

Решить в Pascal. Перед тем как выложить, проверить свое решение.

KaushiKaushik 21 нояб. 2016 г., 6:34:05 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Muhamadieva49
21 нояб. 2016 г., 9:29:14 (7 лет назад)

 var
b:array [1..100] of integer;
   a:array [1..100,1..100] of integer;
   i, j,n,m,k1,k2: integer;
begin
writeln ('Введите Кол-во строк');
readln (n);
writeln ('Введите Кол-во столбцов');
readln (m);
writeln ('Введите к1');
readln (k1);
writeln ('Введите к2');
readln (k2);
for i :=1 to n do
      for j :=1 to m do
         readln ( a [ i , j ]);
         writeln ('Исходный массив');
         for i:=1 to n do
begin
  for j:=1 to m do
  write(a[i,j]:4);
  writeln;
end;
writeln;
     for j :=1 to m do
       b[j]:=a[k1][j];
         for j :=1 to m do begin
        a[k1][j]:=a[k2][j];
        a[k2][j]:=b[j];
      end;
      writeln ('Массив после операций');
      for i:=1 to n do
begin
  for j:=1 to m do
  write(a[i,j]:4);
  writeln;
end;
end.

Ответить

Другие вопросы из категории

Прошу вас, чистейшие умы,помогите мне,бестолочу, перевести эти цифры в буквы.Буду

благодарна!
0011010100100000111000011110000011101011111010111110111011100010

составьте программу ,которая

заполняет массив а[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов,которые больше своего соседа слева

1)Напишите программу, которая вычисляет минимальное из трёх введённых чисел. Используйте функцию.

2)Наибольший общий делитель (НОД) двух или нескольких чисел – это наибольшее число, на которое делятся все заданные числа. Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию.
3)Наименьшее общее кратное (НОК) двух натуральных чисел – это наименьшее число, которое делится нацело на оба исходных числа. Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.
4)Ряд чисел Фибоначчи задается следующим образом: первые два числа равны 1 ( F 1 = F 2 = 1 ), а каждое следующее равно сумму двух предыдущих: F i = F i - 1 + F i - 2 . Напишите программу, которая вводит натуральное число N и выводит N -е по порядку число Фибоначчи. Используйте функцию.

Читайте также

1)Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного.

2)дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов. Использовать три процедуры (заполнение, смена, вывод).

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
Даны два целых числа A и B (A < B). Вывести в

порядке возрастания все целые числа, расположенные между A и B(в том числе A и B),
a также количество N этих чисел
ЦИКЛ с ПАРАМЕТРОВ

Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1<=A,

B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.



Вы находитесь на странице вопроса "Дана матрица размера M × N и целые числа K1 и K2 (1 ≤ K1 &lt; K2 ≤ M).", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.