Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Известно время вылета самолета: НН часов и ММ минут, а также продолжительность полета (НР часов и МР минут). Напишите программу, которая определяет время

5-9 класс

прибытия самолета в аэропорт назначения в виде «чч:мм» Формат входных данных: С клавиатуры вводится четыре числа через пробел НН, ММ, НР, МР, обозначающие соответственно часы и минуты вылета и часы и минуты продолжительности полета. Формат выходных данных: На экран вывести время прибытия самолета в аэропорт назначения в виде «чч:мм

Kristinka987 28 апр. 2013 г., 9:48:09 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Anna253683
28 апр. 2013 г., 12:44:28 (10 лет назад)

Var b,a,hh,mm,hp,mp :integer;
begin
readln(hh,mm,hp,mp);
hh:=hh*60;
hp:=hp*60;
a:=hp+hh+mm+mp;
a:=a div 60;
b:=a mod 60;
writeln(a,':',b);
end.

только тут через интер ввод 

Ответить

Читайте также

помогите!нужно решить до завтра.завтра последний день сдачи индивидуальной работы. «Программирование» 9 класс Задание №1 записать по правилам

изучаемого языка программирования следующие выражения:γ m1m2/r^2 Задание 2 «Вычисления по известным формулам». Написать программу:Найти площадь трапеции по известным основаниям и высоте. Задание №3 «Выделение цифр в записи числа» Написать программу:Дано трехзначное число. Верно ли, что оно заканчивается цифрой 7? Задание №4 «Условный оператор» Написать программу:Даны два целых числа. Составить программу, которая большее число возводит в квадрат, а меньшее увеличивает на 10. Если числа равны, то вывести сообщение «ЧИСЛА РАВНЫ». Задание №5 «Циклы» Написать программу:Напишите программу, которая на отрезке от а до в, выводит на экран все четные числа, оканчивающихся нулем.

Задача «Вирусы»

Для моделирования различных объектов часто применяются так называемые клеточные поля. В простейшем случае – это прямоугольные таблицы, характеризующие некоторую область, а в каждой ячейке таблицы записывается какая-либо информация об исследуемом объекте. В биологии для моделирования распространения вирусов на плоской области в каждой ячейке помечается наличие вируса, а его распространение осуществляется в соседние ячейки по вертикали и горизонтали за одну единицу времени. Некоторые клетки обладают иммунитетом, заразить их невозможно и через них не распространяются вирусы. Требуется написать программу, которая определяет минимально возможное число вирусов, с помощью которых можно заразить всю исследуемую прямоугольную область (за исключением защищённых клеток).
Описание входных данныхВ первой строке входного файла input.txt записаны два натуральных числа n и m -размеры таблицы (количество строк и столбцов соответственно). Известно, что 1 n, m 100. Во второй строке вначале записано одно число k – количество защищённых клеток, а далее записаны 2k чисел – координаты этих клеток xi, yi (0 k n m, 1 xi n, 1 yi m).
Описание выходных данных
В единственную строку выходного файла output.txt нужно вывести одно число –минимально возможное число вирусов.
Примеры входных и выходных данных
input.txt
4 5 3 1 3 2 1 2 2
output.txt 2

Помогите с написанием программ в Помогите с написанием программ в ПАСКАЛЕ

1) Если а>7, то найти сумму BC, иначе найти разность.

2) Определить квадрат числа, если оно положительное, но если отрицательное - куб.

3) Идет К-ая секунда суток. Напечатать сколько полных часов, минут и секунд прошло к данному моменту.

4) В магазине продается костюмная ткань. Ее цена В рублей за квадратный метр. Напишите программу, которая подсчитает и выведет на экран стоимость куска этой ткани, длиной Х метров и шириной 80 см.

Помогите, для кого сообщение о задержке вылета самолета является актуальной информацией? 3) Животных, отправляющихся вместе с хозяевами в

полет.
4) Службы упаковки чемоданов туристов.

1) Туриста, прилетевшего в аэропорт.
2) Туриста, купившего билет на самолет.



Вы находитесь на странице вопроса "Известно время вылета самолета: НН часов и ММ минут, а также продолжительность полета (НР часов и МР минут). Напишите программу, которая определяет время", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.