Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите решить задачу на языке программирования в Turbo Pascal, плиз Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он

5-9 класс

увеличивал пробег на 10% от пробега предыдущего дня. Определить: а) ежедневное увеличение пробега лыжника за третий, четвёртый, ..десятый день тренировок; б) средний путь лыжника за первые 8 дней тренировок; в) сколько дней он будет бегать менее, чем по 15 км; г) в какой день суммарный пробег за все дни превысит 90 км.

Stsopanova 05 июля 2013 г., 12:05:36 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Angel85
05 июля 2013 г., 14:03:09 (10 лет назад)

Program Rast;

Uses CRT;

Var S1,S,L,Sr: real;

      k,n,i:integer;

Begin

   SlrScr;   {очищение экрана}

   S1:=10;  {начальное суммарное расстояние}

   S:=10; {начальное расстояние}

   n:=1; k:=1;

        For i:=2 to 10 do

            begin

            L:=S*0.1; {увеличение расстояния}

            S:=S+L;    {сумма растояний}

            S1:=S1+S; {общий путь}

            if i=8 then Sr:=S1/8; {средний путь за 8 дней}

            Writeln('  ',L:2:2); {Вывод результата за каждый день}           

            end;

         For i:=2 to 20 do

             begin

             n:=i;  {счетчик дней}

             L:=S*0.1;

             S:=S+L;

             if S>15 then break; {break - это досрочный выход из цикла}

             end;

         S:=10; S:=10;

         For i:=2 to 20 do

             begin

             k:=i;

             L:=S*0.1;

             S:=S+L;

             S1:=S1+S;

             if S1>90 then break;

             end;

      Write('Средний путь лыжника за 8 дней'); Writeln(Sr:2:2);

      Write('Столько дней будет бегать меньше чем 15 км '); Writeln(n);

      Write('Суммарный пробег больше 90км за ',k,' дней');

      Readln;

End.

            

Ответить

Другие вопросы из категории

Даны числа a,b,c. Составить программу, выводящую на экран сообщение, в зависимости от того какой треугольник можно построить с такими длина сторон:

равносторонний,равнобедренный или какой либо другой.

Вот ещё одна

Составить программу:Даны а,b,c-целые числа.Если они большн 0-вычислите сумму их квадратов;а если хотя бы одно из них четно-вычислите их сумму и произведение.

Пожалуйста ребят.

Задача 1

Для записи текста используется 128-ми символьный алфавит.30 строк по 70 символов
Сколько мегабайтов информации несет 200 стр текста?
Задача 2
Для записи текста используется 256-ми символьный алфавит текст набраный этим алфавитом содержит 4 кб информации и занимает 4 стр
Сколько символов в строке если на странице 16 символов

2. Текст состоит из 5 абзацев. Известно,

что в каждом из них используются разные параметры шрифта.
Определите, какие параметры шрифта используются в каждом абзаце, если

Читайте также

Помогите, пожалуйста, решить задачу на языке программирования в Turbo Pascal: 1.Дан массив целых чисел, состоящий из 10 элементов.Заполнить его

с клавиатуры. Найти:
-Удвоенную сумму положительных элементов;
-вывести индексы тех элементов, значения которых больше значения предыдущего элемента(начиная со второго).

2.Определить,есть ли 2 пары соседних элементов с одинаковыми знаками.

Помогите, пожалуйста, решить задачи на языке программирования в Turbo Pascal. 1) Определить максимальн

ый элемент квадратной матрицы, расположенный в правой части, ограниченной диагоналями, включая диагональные элементы.

2) Дана таблица с оценками 12 учащихся по девяти предметам. Определить номер предмета, содержащий максимальный средний балл.

Решить задачи на языке программирования в Turbo Pascal: 1) Дан массив, состоящий из 10 чисел, значения могут быть

от -100 до 100. Определить минимальное положительное число.

2) Дан массив, состоящий из 10 чисел. Найдите номера тех элементовв масива, которые наименее различаются.

Решить задачу на языке программирования Pascal.

В текущем месяце бригада в каждый последующий день работы выпускала на три изделия больше, чем в предыдущий. В первый день было выпущено 42 изделия, что составило 67% дневной нормы. В месяце 26 рабочих дней. Сумеет ли бригада выполнить месячную норму?

Решить задания на языке программирования в Turbo Pascal: 1) Выполните тестирование программы: опишите как будут меняться значения переменных и

что появится на экране в результате выполнения программы. Для переменной S ввести строку - 'аб2в457где245*ж'

Program z2;

uses crt;

var s:string;

k,sum,i,n:integer;

begin

readln(s);

i:=1;

repeat

val(s[i],n,k);

i:=i+2;

sum:=sum+n;

writeln(n);

until i>length(s);

writeln(sum);

readkey;

end.

2) Дано предложение. Удалить из него все буквы с



Вы находитесь на странице вопроса "Помогите решить задачу на языке программирования в Turbo Pascal, плиз Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.