Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Заданы первый член арифметической прогрессии а, разность прогрессии d и количество членов прогрессии k. Вычислить k-1 и к-ые члены арифметической

10-11 класс

прогрессии и сумму первых n членов Sn. Если Sn≤25, то вычислить процентное отношение первого и последнего членов арифметической прогрессии . Написать программу на языке Паскаль

Лапусенька 17 дек. 2013 г., 7:02:23 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Biliv
17 дек. 2013 г., 8:45:33 (10 лет назад)

var
  k,i:integer;
  a,b,bk,d,s,p:real;
begin
write('Первый член: ');
readln(a);
write('Разность прогрессии: ');
readln(d);
write('Число членов k: ');
readln(k);
bk:=a+(k-1)*d;
b:=bk-d;
s:=(a+bk)/2*k;
if s<=25 then p:=a/bk*100;
writeln(k-1,' член: ',b);
writeln(k,' член: ',bk);
writeln('Сумма: ',s);
if p>0 then writeln('Первый составляет ',p,'% от последнего')
end.

Ответить

Другие вопросы из категории

Помогите, пожалуйста составить программу:)

В массиве а1, а2, ..., а50 определить
количество нулей

Компьютер подключенный к интернету обязательно имеет интернет адрес ?

Как формируется доменная система имен?
Как работает транспортный протокол? Протокол маршрутизации ?

Читайте также



Вы находитесь на странице вопроса "Заданы первый член арифметической прогрессии а, разность прогрессии d и количество членов прогрессии k. Вычислить k-1 и к-ые члены арифметической", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.