Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

ПОМОГИТЕ С ПРОГРАММОЙ, ПОЖАЛУЙСТА!

5-9 класс

нужно написать программу, которая по вводу с клавиатуры последовательности целых чисел (признак окончания ввода- ввод числа 0) подсчитывает среднее арифметическое НЕЧЕТНЫХ чисел и чисел, КРАТНЫХ 5.

Popi123 24 мая 2016 г., 11:13:13 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
AliNYsiKKK123
24 мая 2016 г., 13:16:34 (7 лет назад)

Var
   A,i:integer;
   B:real;
Begin
repeat
Writeln('Введи число.');
ReadLn(A);
if (A mod 10 =0) then
 Begin
  i:=i+1;
  B:=A+B;
 End;
until (A=0);
WriteLn('Среднее арифметическое нечетных чисел кратных 5 равно: ',B/(i-1));
ReadLn
End.

+ 0 -
Знайка007
24 мая 2016 г., 13:52:23 (7 лет назад)

Var x,i:integer;
   y:real;
Begin
writeln('Признак окончания ввода - ввод числа 0');
repeat
Writeln('Введите число');
ReadLn(x);
if (x mod 2 >0) and (x mod 5 = 0) then 
Begin  i:=i+1; 
 y:=x+y; 
End;
until (x=0);
WriteLn('Среднее арифметическое нечетных чисел кратных 5 = ',y/i);
End.

+ 0 -
199823nastusha
24 мая 2016 г., 15:50:15 (7 лет назад)

аа мне тоже нужна эта задача

Ответить

Другие вопросы из категории

У меня кроссворд не могу догадаться.

1. Подход, при котором учитывается взаимодействие и взаимовлияние всех компонентов системы (два слова) (1 слово-9 букв, 2 слово-6 букв.
2. Описание системы, при котором указываются её входы и выходы, а также зависимость между ними (6 букв).
3. Система, входящая в состав другой системы (10 букв).
4. Появление у системы новых признаков, которыми не обладал ни один из её элементов в отдельности (два слова) (1 слово-9 букв, 2 слово-6 букв).
5. Система, включающая в себя другую систему (10 букв).
ПОМОГИТЕ ПЛИЗ ОЧЕНЬ НУЖНО!!!

решитее........................

Читайте также

Помогите написать программы, пожалуйста!

1) Какое количество теплоты выделяет обычная лампа накаливания мощностью P за время t? На тепло уходит 60% всей энергии. {E=P*t}.
2) Хватит ли денег S на покупку товара, если единица товара стоит C? Сколько товара можно купить?



Вы находитесь на странице вопроса "ПОМОГИТЕ С ПРОГРАММОЙ, ПОЖАЛУЙСТА!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.