Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

паскал дан массив найти среднее арифметическое

5-9 класс

Sabrinausaeva 12 июля 2016 г., 6:50:19 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tuhvatshin1975dfdf
12 июля 2016 г., 7:59:00 (7 лет назад)

Одномерный массив с рандомными 10-ю элементами:
var
a:array [1..10] of integer;
i,s:integer;
sa:real;
begin
randomize;
for i := 1 to 10 do
begin 
 a[i]:=random(20);
  write(a[i],' ');
end;
s:=0;
 for i := 1 to 10 do
   s:=s+a[i];
   sa:=s/10; 
  writeln;
   write('srednee arifmetisheskoe = ',sa:3:3);
   readln;
end.

Ответить

Другие вопросы из категории

Ребят,очень срочно. 1. С какой целью проводится вычислительный эксперимент?

2. В чем отличие задач, решающихся методом математического моделирования, от задач, решающихся

Помогите, пожалуйста.

134 в пятеричной системе счисления перевести в 10-тичную (как вы это сделали!??!)
321 в четверичной системе счисления в десятичную))

Подскажите как решать.)

Заранее спасибо!

Читайте также

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

составить программы в Паскале:

1)Дан массив из 10 элементов. Найти среднее арифметическое.
2)



Вы находитесь на странице вопроса "паскал дан массив найти среднее арифметическое", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.