Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Паскаль.

10-11 класс

Дана строка, содержащая слова, разделенные одним пробелом. Напечатать все слова, отличные от последнего слова.

89260683823 23 июля 2013 г., 4:18:14 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ШакРус
23 июля 2013 г., 6:59:48 (10 лет назад)

var
  s: string;

begin
  readln(s);
  write(s.Split(' ')[0], ' ');
  foreach s1: string in s.Split(' ') do
    if (s1 <> s.Split(' ')[0]) then
      write(s1, ' ');
end.

Ответить

Другие вопросы из категории

Напишите программу для вычисления значений функции

F(x)={x^3-3x8 если х<=1
{1/(x^3-3x8) если х>1

В языке Pascal есть функция Pandom (a), которая служит для получения случайного ряда чисел из интервала (0;а). Вопрос: придумать, как можно при помощи

формул языка Pascal сделать так, чтобы случайные числа выпадали в интервале (a;b)

Поместиться ли на стандартном CD диске информация учебника по информатики.?

Объём СD = 720 мбайт
Символов в строке- 58
Строк на странице- 42
Страниц- 435

Толя получает информацию из интернета со скоростью 2^18 бит/с и передает ее Мише со средней скоростью 2^15 бит/с. Компьютер Толи может начать

ретрансляцию данных не раньше, чем им будут получены первые 256 Кбайт этих данных. каков минимально возможный промежуток времени в секундах с момента начала скачивания Толей данных размером 2 Мбайта до полного их получения Мишей.

Читайте также

Рассказать и показать на примере Паскаль: 1) Что такое absolute и для чего нужна? 2) Что такое asm и для чего нужна? 3) Что такое

constructor и destructor и для чего нужна?

4) Что такое implementation и для чего нужна?

5) Назовите модули Паскаль ( в строке Uses, например crt) и какие возможности этот модуль дает?

6) Что за тип переменной: указательный (Pointer)

7) И на последок: что означает символ @ , #, $ , ^

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

ПАСКАЛЬ!

как на языке паскаль записать
корень5x - корень4y +1
??

Прошу переделать код программы с языка Паскаль на С++.

Вот код Паскаль:
var
f:array[1..500] of record
fam:string;
bal:boolean;
end;
buf:boolean;
str:string;



Вы находитесь на странице вопроса "Паскаль.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.