Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дано множество точек с координатами на плоскости.

10-11 класс

Написать программу, которая использует подпрограммы и выведит на экран наименьшее расстояние между двумя точками.

Georgiy495 23 апр. 2013 г., 4:49:23 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
EvgeniaV
23 апр. 2013 г., 6:32:38 (11 лет назад)

const
  nm = 50;{максимальная длина массива}

type
  Mas = array[1..nm] of real;

var
  i, j, n: integer;
  x, y: Mas;
  d, dmin: real;

function SqrDist(p, q: integer): real;
{ Возвращает квадрат расстояния между точками }
begin
  SqrDist := sqr(x[q] - x[p]) + sqr(y[q] - y[p])
end;

begin
  Write('Введите количество точек -> ');
  Readln(n);
  Writeln('Вводите координаты каждой точки (x,y) через пробел');
  for i := 1 to n do
  begin
    Write('точка ', i, ': ');
    Readln(x[i], y[i]);
  end;
  dmin := 1e10; { значение, заведомо большее реально возможного }
  for i := 1 to n do
    for j := i + 1 to n do
    begin
      d := SqrDist(i, j);
      if dmin > d then dmin := d
    end; 
  Writeln('Минимальное расстояние между точками равно ', sqrt(dmin):0:4)
end.

Тестовое решение:

Введите количество точек -> 5
Вводите координаты каждой точки (x,y) через пробел
точка 1: 3.4 7.2
точка 2: -3 8.6
точка 3: -4.5 -5.1
точка 4: 6 -2
точка 5: 0 9
Минимальное расстояние между точками равно 3.0265


+ 0 -
Maiskhahikyan
23 апр. 2013 г., 7:55:50 (11 лет назад)

Паскаль?

Ответить

Другие вопросы из категории

Вычислить у(х), если у=х^2 при х>1 и у=х при х<=1

Паскаль

С++

Фрагмент кода
int value;
int bit[15];
printf("Enter value: ");
scanf("%d",&value); //тут вводим value
printf("\n\nvalue: %d",value); //выводится наше value
bit[15]=(value<0)?1:0; //тут value почему то зануляется
printf("\n\nvalue: %d",value); //выводим уже 0.

вопрос, почему зануляется?

Была исходная последовательность символов:

AABABAAA

Читайте также

Два игрока играют в игру. На координатной плоскости стоит фишка. Игроки ходят поочереди. В начале игры фишка находится в точке с координатами (4,2).

Ход состоит в том, что игрок перемещает фишку из точки с координатами (x,y) в одну из трех точек: или в точку с координатами (x+3,y), или в точку с координатами (x,y+3), или в точку с координатами (x,y+4). Выигрывает игрок, после хода которого расстояние по прямой от фишки до точки с координатами (0,0) не меньше 10 единиц. Кто выигрывает при безошибочной игре – первый или второй игрок? На каком шаге игры произойдет выигрыш? Каким должен быть первый ход выигрывающего игрока?

расписать в паскале: На плоскости расположена окружность R в центре с началом координат.Определить положение точки X с координатами (A,B) относительно

окружности (лежит ли точка внутри окружности на окружности или вне ее) Если можно полностью

Кузнечик стоит на координатной прямой в точке с координатой 0. Кузнечик может выполнять только две команды "вправо на 7" и "влево на 5". Запишите

последовательность из этих команд для кузнечика которая позволит ему оказаться в точке с координатой 6



Вы находитесь на странице вопроса "Дано множество точек с координатами на плоскости.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.