Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Создать программу в Паскале, 9 класс

5-9 класс

Поменять местами первый элемент масива и максимальный.
Заранее Спасибо) Помогите пожалуйста) Очень срочно!!)
var a: array [1..20] of integer;

Na5alya 23 апр. 2015 г., 15:01:53 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Лариса0306
23 апр. 2015 г., 17:15:18 (9 лет назад)

var  
a: array[1..50] of integer;  
i,n,max,r: integer;
Begin  
randomize;  
readln(n);  
for i:=1 to n do    
begin      
a[i]:=random(50)-25;      
write(a[i]:4);    
end;  
writeln;  
max:=1;  
for i:=1 to n do    
if a[i]>a[max] then max:=i;  
r:=a[1];  
a[1]:=a[max];  
a[max]:=r;  
for i:=1 to n do write(a[i]:4);  
readln
End.

Ответить

Другие вопросы из категории

Программа на Pascal ABC. С клавиатуры вводится маленькими русскими буквами строка, необходимо для каждого символа вывести, а) сколько раз его употребили и

б) частоту употребления (отношение а к длине строки, не считая пробелов).
Примечание 1. Выводить только для маленьких русских букв, пробелы не трогать.
Пример. Вводится строка 'раз два три'. нужно вывести:
р - 2 раза, ч.у - 0.27 //Округление до сотых
... Ну и так далее. Два раза один и тот же символ не выводить!
Вводить новые переменные можно в любом количестве.


Читайте также

Пожалуйста помогите создать какую нибудь полезную программу на паскаль , срочно нужно до понедельника, чтобы в этой программе были все темы за 8 класс,

read.writeln.else.to.if и тд которые сможете
Вот пример идеи для программы, в академию поступают какое то количество учеников, нужно написать сколько учеников сдали документы, сколько пришли на экзамен, и сколько учеников кто прошло и не прошло
возможно не возможно создать программу на этой идее, тогда прделагайте свои со своими программами , пожалуйста помогите!

Помогите, пожалуйста, написать программу в Паскаль

Если дано трехзначное число, например 123 его можно представить в виде 3+2*10+1*10*10. Воспользовавшись этой информацией, создайте программу, которая, получая от пользователя трехзначное число, будет определять из каких цифр оно состоит и выводить их через пробел (например, 1_2_3).



Вы находитесь на странице вопроса "Создать программу в Паскале, 9 класс", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.