Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Кто решит, тот молодечик! Дана матрица ( массив ) A(N;M). Вывести на экран массив A(N;M) и сумму элементов этого массива, находящихся в строке х.

5-9 класс

Размеры массива A(N;M) и номер строки х вводятся с клавиатуры, а элементы задаются ГСЧ (RANDOMIZE)

Vadimkolesnik 04 сент. 2016 г., 17:43:18 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zaywka
04 сент. 2016 г., 18:30:51 (7 лет назад)

uses crt;
var a:array [1..99, 1..99] of integer;
i,j,n,m,x,z:integer;
begin
clrscr;
randomize();
z:=0;
writeln('Введите количество строк');
readln(n);
writeln('Введите количество столбцов');
readln(m);
writeln('Введите номер строки');
readln(x);
for i:=1 to n do
for j:=1 to m do
begin
a[i,j]:=random(10);
if x=i then z:=z+a[i,j];
end;
for i:=1 to n do
begin
for j:=1 to m do
write(a[i,j]:2, ' ' );
writeln();
writeln;
end;
writeln('Сумма ',x,' строки=',z);
readln();
end.


Ответить

Другие вопросы из категории

Имеются: (а) видео файл, (b) аудио файл, (с) текстовой файл и (d) графический файл. Для какого файла НЕВЕРНО выбран набор устройств, подходящий для его

воспроизведения?
1. монитор 2. принтер 3. колонки 4. сканер
A) a- 1,3 Б) b - 2,4 В) с - 1,2 Г) d - 1

СРОЧНО ПОМОГИТЕ

определить что будет напечатано в результате работы с этой программой

Тег<PRE> языка программирования HTML означает:

1) Создание простой формы
2) Сохранение пробелов
3) Данные ячеек таблицы
4) Количество строк таблицы

Составьте программу, которая осуществляет преобразование единиц измерения физических величин:

а) Значение скорости, измеренные к км/ч, преобразуются в значения, измеренные в м/с (1м/с=3,6км/ч)

Читайте также

Дан одномерный массив B из N элементов, значения которых находятся в диапозоне от 0 до 325.

1) Заменить все чётные элементы на их номера. Вывести на экран исходный и новый массив.
2) Заменить все чётные элементы, стоящие на нечетных местах, на их номера.

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

1)Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2)Задан массив из 11 целых чисел. Посчитать количество нечётных

элементов массива.

3)задан массив из 9 целых чисел.Вывести на экран чётные элементы



Вы находитесь на странице вопроса "Кто решит, тот молодечик! Дана матрица ( массив ) A(N;M). Вывести на экран массив A(N;M) и сумму элементов этого массива, находящихся в строке х.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.