Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Описать функцию square(k) логического типа, возвращающую True, если целый параметр k(>0) является квадратом некоторого числа, и False в противном

5-9 класс

случае. Паскаль

324fvfdv 30 авг. 2014 г., 18:56:57 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
12358486864286
30 авг. 2014 г., 19:35:05 (9 лет назад)

var k: integer;
function square(k: integer): boolean;
begin
     if sqr(trunc(sqrt(k))) = k  {Проверяем, является ли квадрат округлённого квадратного корня самим числом}
     then
         square := true
     else
         square := false;end;
begin
     read(k);
     writeln(square(k));
end.

Ответить

Другие вопросы из категории

Составьте программу стоимости покраски пола в комнате: Вводимые данные: Стоимость 1 кг краски- Длина комнаты- Ширин

а комнаты-

Известно,что для покраски одного м2 требуется 150 г краски

ПОМОГИТЕ!!!ЛЧЕНЬ НУЖНО!БУДУ ОЧЕНЬ БЛАГОДАРНА)

В одном из изданий книги Л.Н. Толстого «Война и мир» 1024 страницы.

Какой объём памяти (в Мбайт) заняла бы эта книга, если бы Лев Николаевич
набирал её на компьютере в одной из кодировок Unicode? На одной странице
в среднем помещается 64 строки, а в строке 64 символа. (Каждый символ
в кодировке Unicode занимает 16 бит памяти.)
Помогите пожалуйста))

Читайте также

Помогите пожалуйста решить!)

Составить программу, которая печатает true, если точка с координатами (х, у) принадлежит заштрихованной области, и false в противном случае:

нужно написать программу в ПАСКАЛЕ

Описать функцию Quarter(x, y) целого типа, определяющую номер координатной четверти, в которой находится точка с ненулевыми вещественными координатами (x, y). С помощью этой функции найти номера координатных четвертей для трех точек с данными ненулевыми координатами.

1. Язык программирования Pascal создал:

a. Н. Вирт

b. Б. Паскаль

c. М. Фортран

d. Правильных ответов нет

2. Линейная структура построения программы подразумевает

a. Неоднократное повторение отдельных частей программы

b. Последовательное выполнение всех элементов программы

c. Выполнение лишь нескольких, удовлетворяющих заданному условию частей программы

d. Верного ответа нет

3. Оператор присваивания имеет вид:

a. =

b. :=

c. =:

d. Верного ответа нет

4. Команда CLRSCR служит для

a. ожидания нажатия клавиши

b. ввода данных с экрана

c. очистки экрана

d. верного ответа нет

5. раздел VAR служит

a. Для описания используемых переменных

b. Для описания величин

c. Для описания выражений

d. Верного ответа нет

6. Переменные – это:

a. величины, которые могут менять свое значение в процессе выполнения программы

b. величины, которые не могут менять своего значения в процессе выполнения программы

c. обозначают строки программы, на которые передается управление во время выполнение программы

d. Верного ответа нет

7. Правильная строковая запись выражения

a. x-х***3/abs x + sin (x)

b. x-x*x*x/abs (x) +sin (x)

c. x-(x*x*x)/abs (x) +sin (x)

d. Верного ответа нет

8. целочисленное деление можно выразить следующей функцией:

a. A mod B

b. A div B

c. Abs (A)*B

d. Верного ответа нет

9. математическое выражение х2-7х+6 можно записать:

10. выражение на паскале

(abs (x)-abs(y))/(1 + abs (1/s)) можно записать:

11. раздел операторов начинается служебным словом:

a. VAR

b. INTEGER

c. BEGIN

d. Верного ответа нет

12. ввод данных с клавиатуры осуществляется с помощью оператора:

a. WRITE, WRITELN

b. READ, READLN

c. PROGRAM

d. Верного ответа нет

13. вывод данных на экран осуществляется с помощью оператора:

a. WRITE, WRITELN

b. READ, READLN

c. PROGRAM

d. Верного ответа нет

14. чему будет равно значение переменной М в результате выполнения серии операторов
N:=5;

Y:=2;

M:=N/5+3*Y*N

15. тип переменных REAL это:

a. целочисленный тип

b. логический тип

c. натуральный тип

d. верного ответа нет





Вы находитесь на странице вопроса "Описать функцию square(k) логического типа, возвращающую True, если целый параметр k(>0) является квадратом некоторого числа, и False в противном", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.