Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Напишите программу, которая выводит на экран массив случайных двузначных чисел а[1..10,1..20] и находит количество отрицательных элементов в этом массиве.

10-11 класс

Пожалуйста решите задачу путем программирования, и буду благодарен если меня тоже научите алгоритму решения!!!

Пашка199997 29 марта 2016 г., 23:07:42 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
123456654321qw
30 марта 2016 г., 1:15:31 (8 лет назад)

 const n=10;m=20;
 var i,j,k:integer; 
     a:array[1..n,1..m] of integer;
begin 
randomize; 
for i:=1 to n do   
  for j:=1 to m do   
         a[i,j]:=random(100)-random(100);
  for i:=1 to n do   begin    writeln;
    for j:=1 to m do     begin
      write(a[i,j]); 
      if (a[i,j]>=0)and(a[i,j]<10) then write('   ') else
      if (a[i,j]>-10)and(a[i,j]<0)or(a[i,j]>=10) then write('  ') else
      write(' ');
      if a[i,j]<0 then k:=k+1;
     end;
   end;
  writeln;
  write('количество отрицательных элементов =',k);
  readln;
end.

+ 0 -
Gulnaz8917
30 марта 2016 г., 3:29:19 (8 лет назад)

Задали на дом такое условие, и сказали на Паскале решить.

+ 0 -
Ksusha100396
30 марта 2016 г., 5:19:58 (8 лет назад)

ладно сейчас сделаю

+ 0 -
Karinamosunova
30 марта 2016 г., 8:10:39 (8 лет назад)

вы еще не учили вывод в файл?

+ 0 -
Nora3838
30 марта 2016 г., 11:06:49 (8 лет назад)

Ну да, но я не очень хорошо знаю. Меня тоже научи

+ 0 -
Eljza
30 марта 2016 г., 12:42:17 (8 лет назад)

Поджди почти дописал

Ответить

Читайте также

1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов.

2. Написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.

эллементы массива вычисляются по формуле A(X,Y)=2X^2-Y^2 написать программу, которая выводит на экран значения элементов массива А(2,2).

подсчитать количество отрицательных элементов

сумму положительных элементов

ВЫВОДИТ НА ЭКРАН НОМЕРА ВСЕХ ЭЛЕМЕНТОВ, ЗНАЧЕНИЯ КОТОРЫХ =0

Написать программу, которая считает и выводит на экран сумму всех целых чисел из промежутка [A, B]. Числа A и B задает пользователь.

Программу реализовать с помощью трех циклических алгоритмов:
1) Цикл со счетчиком for
2) Цикл с предусловием while
3) Цикл с постусловием repeat
В программе предусмотреть ситуацию, когда пользователь вводит значение B ‹ A
Пример 1:
Пользователь вводит числа A=5, B=10. Сумма чисел: 5+6+7+8+9+10. Вывод на экран: 45
Пример 2:
Пользователь вводит числа A=7, B=4. Сумма чисел: 4+5+6+7. Вывод на экран: 22
Пример 3:
Пользователь вводит числа A=5, B=5. Сумма чисел: 5. Вывод на экран: 5

1)Написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)Написать программу, которая выводит на экран перевёрнутый

текст.

3)Написать программу, которая определяет является ли слово палиндромом.

4)Написать программу, определяющую какая из букв а или о встречается в тексте первой.

Помогите хотябы одну пожалуйста))Нужно до завтра!))

1)Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру.

2)Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
3)Напишите программу, которая выводит в одну строчку все делители переданного ей числа, разделяя их пробелами.
4)Напишите программу, которая выводит в столбик цифры введённого числа, начиная с первой. Используйте процедуру.



Вы находитесь на странице вопроса "Напишите программу, которая выводит на экран массив случайных двузначных чисел а[1..10,1..20] и находит количество отрицательных элементов в этом массиве.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.