Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

помогите срочно!!! 10 класс

10-11 класс

составить программу,которая вводит элементы массива с клавиатуры (10 элементов) и выводит только четные элементы

Coolschet 01 сент. 2016 г., 11:31:33 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gaevskaya02
01 сент. 2016 г., 12:03:56 (7 лет назад)

program E01;
  uses crt;
    var
      X: array[1..50] of integer;
      S,i: integer;
begin
  clrscr;
  writeln('Введите 10 элементов массива: X');
  for i:=1 to 10 do
  begin
     writeln('X[',i:2,'] ==> ');
     readln(X[i])
  end;

  writeln('Четные элементы массива: ');
  for i:=1 to 10 do
    begin
      S:=X[i] mod 2;
      if S = 0 then
        writeln(X[i],' ') 
    end;
 
  if S <> 0 then
    writeln('Нет четных чисел!')
end.

+ 0 -
Khachay
01 сент. 2016 г., 15:01:52 (7 лет назад)

Так конкретно только 10 элементов? Второе, на чем программу надо? И третье, массив одномерный или многомерный (вектор,матрица)?

+ 0 -
Pechenkaaa
01 сент. 2016 г., 16:43:12 (7 лет назад)

конкретно 10 элементов,писать на паскале,массив одномерный

+ 0 -
Nuralievahmed
01 сент. 2016 г., 19:38:06 (7 лет назад)

Хорошо секундочку

Ответить

Другие вопросы из категории

Якщо змінна Х=-12 то накладена умова (х>=12) or (x<=12) буде

Задано цикл For i:= 0,2 to 0,5 do Скільки разів
повториться даний цикл?

Заполнить массив из 10 элементов случайными числами в интервале [-8;13] [-10;25] [98;101] [-5;15] и найти в нем максимальный и минимальный элементы и

их номера.

Пример: Исходный массив: 4 -5 3 10 -4 -6 8 -10 1 0

максимальный a[4]=10

минимальный a[8]=-10

Читайте также

Помогите срочно!

10 класс

Паскаль

Помогите пожалуйста 10 класс . много чего ещё не понимаю
1) Определите сумму четных чисел до числа N введённые с клавиатуры
N=10
S=2+4+6+8+10=30
2) Составить программу которая вводит с клавиатуры число N и определяет произведение всех чисел
N=4
P=1*2*3*4=24
помогите пожалуйста



Вы находитесь на странице вопроса "помогите срочно!!! 10 класс", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.