Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Даны 2 двузначных целых числа X и y.Найти D=MAX{x+y;y-x}+3,E=MIN{x^2+y^2;y^2+x*y}-4.если D<E,то к переменной D прибавить первую цифру числа

10-11 класс

E,иначе из числа взять корень степени, равной второй цифре числа

если есть умеющте напишите,пожалуйста,программу в Паскале

Andreevaoks 17 янв. 2014 г., 13:13:39 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
IshmuratovDen
17 янв. 2014 г., 16:01:36 (10 лет назад)

var x,y,k,err:integer;s:string;d,e:real;
begin
err:=0;
read (x,y);
d:=max (x+y,y-x) + 3;
e:=min (sqr(x)+sqr(y),sqr(y)+x*y) - 4;
str (e,s);
k:=length(s);
val (s,e,err);
if (d<e) then
begin
d:=d+(e div (10*(k-1)));
end else
begin
d:=power (d,1/(e div (10*(k-2))));
end;
writeln (d);
end.

Ответить

Читайте также

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

1)Ввести целое число и найти произведение его четных цифр. Пример: Введите целое число: 1234. Произведение четных цифр числа 1234 равно

6.

2)Ввести целое число и определить количество черных и нечетных цифр.

Пример:

Введите целое число :12547

количество нечетных цифр:3

количество четных цифр:2

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
Всем привет! Помогите пожалуйста по информатике. Задача: ввести целое число и найти сумму его цифр. Пример: введите целое число:1234. Сумма цифр числа 1

234 равна 10. Задача: сумма цифр ввести целое число и определить верно ли, что в его записи есть 2 одинаковые цифры. Пример: введите целое число 1234 нет введите целое число 1224 да

Помогите надо написать программу в паскале. 1)координаты двух различных полей шахматной доски x1, y1,x2, y2 (целые числа, лежащие в диапазоне 1–8).

Проверить истинность высказывания: «Ладья за один ход может перейти с одного поля на другое». 2) Дано трехзначное число. Проверить истинность высказывания: «Все цифры данного числа различны». 3)Даны две переменные целого типа: A и B. Если их значения не равны, то присвоить каждой переменной сумму этих значений, а если равны, то присвоить переменным нулевые значения. Вывести новые значения переменных A и B.



Вы находитесь на странице вопроса "Даны 2 двузначных целых числа X и y.Найти D=MAX{x+y;y-x}+3,E=MIN{x^2+y^2;y^2+x*y}-4.если D&lt;E,то к переменной D прибавить первую цифру числа", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.