Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Задача:

5-9 класс

Дан массив из 10 целых чисел,от -20 до 20 .
Напишите программу,заменяющую первый отрицательный элемент массива нулем.

Помогите пожалуйста решить!

ЕкатеринаКириллова 29 июля 2013 г., 21:27:09 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ляляля69жужужу
29 июля 2013 г., 22:39:42 (10 лет назад)

Program z10;
var a,b:Array [1..10] of integer;
i,q:integer;
Begin
Randomize;
q:=0;
For i:=1 to 10 do
begin
a[i]:=random(40)-20;
write(a[i],' ');
if(a[i]<0)then begin
q:=q+1;
if(q=1)then a[i]:=0;
end;
end;
writeln;
for i:=1 to 10 do
begin
write(a[i],' ');
end;
end.

+ 0 -
Aynuro4kak
30 июля 2013 г., 0:58:32 (10 лет назад)

var a:array [1..10] of integer;
     i,n,b:integer;
Begin
  for i:=1 to 10 do
    read(a[i]);
  for i:=1 to 10 do
  begin
    if b=0 then if a[i]<0 then 
       begin
         a[i]:=0;
         b:=1;
       end;
  end;

  for i:=1 to 10 do
  write(a[i],' ');
End.

+ 0 -
444444444444444444
30 июля 2013 г., 1:32:10 (10 лет назад)

язык?)

+ 0 -
7Yanochka7
30 июля 2013 г., 4:08:07 (10 лет назад)

паскаль

Ответить

Другие вопросы из категории

Помогите пожалуйста!!!

Какие из следующих моделей является информационными, а какие натурными.
Математическая формула.
Манекен.
Муляж.
Сборочный чертеж.
Оглавление книги.
Блок-схема алгоритма.
Авиамодель.
эталон метра.
Программа телепередач.
Схема метрополитена.
Карта местности.


файл размером 9 Кбайт передается через некоторое соединение со скоростью 1024 бит в секунду. определите на сколько секунд быстрее можно передать этот

же файл через другое соединение сос коростью 2048 бит в секунду. в ответе укажите одно число - количество секунд.

Читайте также

Решите задачу

Решите задачу с помощью рассуждения (рассуждения присылать тоже)
Задача: В одном доме живут 3 товарища: Вася, Боря и Дима.
Один из них играет в футбол, другой пишет стихи, а третий лучше всех играет в шахматы.
Известно : 1-ВАсин друг с огорчением сказал "Вчера я не сумел реализировать пинальти" 2-товарищ поэта сказал" Дима! Написал бы и ты что нибудь и для нашей футбольной команды"
Назовите имена футболиста, шахматиста, поэта (с рассуждением)

Помогите решить задачу!!!!

Очень нужно)
Задача 11!!!!!))))

Решите задачу 9 класс. Срочно! Много баллов!

Достаточно ли видеопамяти объемом 256 кбайт для работы монитора в режиме 640х480 и палитрой из 16 цветов.
Оформить как задачу (Дано, решение, все формулы и т.п)

Задача по икт в виде таблицы истины ( дизъюнкция, коньюкция, инверсия )

Задача:
не (a или b) и (c или b)

ЗАДАЧИ!

1) Фокусник высыпает на стол 501 монету достоинством в один рубль и предлагает задачу: разложить деньги по девяти кошелькам так, чтобы можно было уплатить любую сумму от 1 рубля до 501, не открывая кошельков. Как можно разложить монеты?

2) Микрокалькулятор позволяет с введённым в него числом две операции: умножать на 2 или переставлять его цифры. Можно ли получить из числа 1 число 120?

3) Составьте алгоритмы для исполнителя Черепашка ( в среде ЛогоМира, Кумир )



Вы находитесь на странице вопроса "Задача:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.