Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

дано n чисел , определить номер максимального значения

10-11 класс

Лёля27 15 марта 2014 г., 19:33:57 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Filippova190906
15 марта 2014 г., 21:32:37 (10 лет назад)

const n=5;
var a:array [1..n] of integer;
imax,i,max:integer;
begin
for i:=1 to n do
read(a[i]);
max:=a[1];
for i:=2 to n do
if a[i]>max then
begin
max:=a[i];
imax:=i;
end;
write(i);
end.

+ 0 -
Sfilipp17
15 марта 2014 г., 22:06:07 (10 лет назад)

const n=5;

Ответить

Другие вопросы из категории

Читайте также

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

Помогите, пожалуйста. Нужно написать программу паскаль.. 7.62. Даны натуральное число n и целые числа a1, a2, a3, …a9. Найти: а) номер максимального из

чисел ai,. Если чисел с максимальным значением несколько, то должен быть найден номер последнего из них; б) номер минимального из чисел ai,. Если чисел с минимальным значением несколько, то должен быть найден номер первого из них;

вот задание: дано: массивы А(10),В(10),С(10). Сформировать массив D(10), каждый элемент которого есть максимальное значение соответствующих

элементов А,В,С, т.е. Di=MAX{Ai,Bi,Ci}. Нахождение максимального значения оформить в виде подпрограммы.а вот подпрограмма:

Procedure FindMax(A,B,C:real; Var D:real);
Begin
if (A>B)and(A>C) then D:=A;
if (A<B)and(B>C) then D:=B;
if (C>B)and(A<C) then D:=C;
End;
Var
A,B,C,D:array[1..10] of real;
i:integer;
Begin
Write('A: ');
For i:=1 to 10 do
Begin
A[i]:=random(100)-25;
Write(A[i],' ');
End;
WriteLn;
Write('B: ');

Паскаль

Задан целочисленный массив A[n]. Определить, сколько раз меняется знак в данной последовательности чисел, запомнить номера позиций, в которых происходит смена знака.



Вы находитесь на странице вопроса "дано n чисел , определить номер максимального значения", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.