Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Помогите сделать задачи 9.2 9.3

10-11 класс

Pascal

JustDoctor 26 окт. 2015 г., 10:41:39 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
AngeBenge
26 окт. 2015 г., 11:18:02 (8 лет назад)

program Ex92;

const
  n = 10;

var
  C: array[1..n] of integer;
  i: integer;

begin
  Randomize;
  for i := 1 to n do C[i] := random(30) - 15;
  writeln('Исходный массив');
  //Вывод в столбец
  for i := 1 to n do writeln(C[i]:4);
  //Вывод в строку
  for i := 1 to n do write(C[i]:4);
  writeln;
  //Основная часть
  writeln('Элементы, кратные своему номеру');
  for i := 1 to n do
    if abs(C[i]) mod i = 0 then write(c[i]:4);
  writeln()
end.

Пример работы программы:
Исходный массив
  -3
   8
   7
   0
  -8
  11
   8
   4
  10
 -10
  -3   8   7   0  -8  11   8   4  10 -10
Элементы, кратные своему номеру
  -3   8   0 -10

program Ex93;

const
  n = 10;

var
  C: array[1..n] of integer;
  i, max: integer;

begin
  Randomize;
  for i := 1 to n do C[i] := random(30) - 15;
  writeln('Исходный массив');
  //Вывод в столбец
  for i := 1 to n do writeln(C[i]:4);
  //Вывод в строку
  for i := 1 to n do write(C[i]:4);
  writeln;
  //Основная часть
  max := -20;  //меньше меньшего
  for i := 1 to n do
    if C[i] < 0 then
      if C[i] > max then max := C[i];
  writeln('Максимальный элемент среди отрицательных:', max:4)
end.

Пример работы программы:
Исходный массив
   9
   8
  -5
 -11
  -2
 -15
   3
 -15
 -14
  -3
   9   8  -5 -11  -2 -15   3 -15 -14  -3
Максимальный элемент среди отрицательных:  -2






Ответить

Другие вопросы из категории

1)Доказать (путем перебора возможных значений), что для любых величин А, В, С типа Boolean следующая пара логических выражений имеет одинаковые значения

(эквивалентны): (A AND B) AND C и A AND (B AND C).

2)Найдите все трехзначные числа, которые можно представить разностью между квадратом числа, образованного первыми двумя цифрами и квадратом третьей цифры.

Однажды один программист поместил объявление о прадаже устройства вывода звуковой информации, однако по случайности

перепутал и в объявлении было написанно о продаже маленькой собачки, декоративной породы. Разрешите путаницу и напишите , что же хотел выставить на продажу невнимательный программист.

Все 5-буквенные слова, составленные из 5 букв А, К, Л, О, Ш,

записаны в алфавитном порядке.

Вот начало списка:

1. ААААА

2. ААААК

3. ААААЛ

4. ААААО

5. ААААШ

4. АААКА

……

Какое слово следует за словом ШАЛАШ?

Читайте также

Здравствуйте. Помогите сделать задачу на PascalABC, попросили сделать с помощью записей.

Составить программу, которая
вводит данные о студентах:

№ п/п, фамилию, год рождения, пол, курс, вид спорта и выводит:

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

Пожалуйста, помогите с задачей в паскале! Написать решение задачи для программы Паскаль. Спасибо)

Имеется
массив А из N произвольных чисел (А(N)), среди которых есть положительные, отрицательные и
равные нулю. Используя оператор цикла, составить программу, выполняющую задачу:

Помогите пожааалуйста,вообще нереально сделать(задачи зависят друг от друга) 1.заполнить массив из 100 элементов случайными числами.вывести на

экран с 20 по 50 в строку через пробел

2.для первыз десяти элементов найти среднее арифмитическое

3.вывести на экран только четные элементы с 1 по 10 элементы массива

4.найти сумму нечетныз значений с 20 по 50 элемент

5.найти количество элементов кратныз заданному числу,введёного с клавиатуры среди всез элементок линейного массива



Вы находитесь на странице вопроса "Помогите сделать задачи 9.2 9.3", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.