Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

помогите решить задание на паскаль используя формат if.

10-11 класс

Subar2kl 23 мая 2014 г., 9:33:28 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
AlbertGaan
23 мая 2014 г., 10:05:24 (9 лет назад)

Что бы не запускать каждый раз программу ввёл цикл repeat until. Если хочешь убери
var x,y,a:real;
begin
repeat
readln(x);
if (x=5) or (x=6) or (x=7) then
y:=x;
if (5y:=x-5;
begin if (6y:=x-6;
end;
writeln(y:0:5);
until false
end.

Ответить

Другие вопросы из категории

HELP!HELP!

Составить программу по нахождению минимального элемента массива и определить его местонахождение в массиве.

дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые числа от о до 10000 включительно. Опишите на естественном языке или на

одном из языков программирования алгоритм, позволяющий найти и вывести максимальное значение среди трехзначных элементов массива, оканчивающихся на 0

Читайте также

Помогите пожалуйста решить задание на Паскале по оператору перехода! Даны различные действительные числа a, b,

c, d.

Найти max (max(a, b), max(a, c), max(a, d)).Числа получить случайным
образом на интервале [-50..+50]

Помогите решить задачу на паскале, очень нужно:

Дана строка, удалить текст находящийся в скобках (вместе со скобками)

Я тут начал делать, вот только с удалением у меня ничего не получается, напишите как можно сделать

Вот как я делал:
program zd;
uses crt;
var s:string; i,l,n,t,y:integer;
begin
clrscr;
writeln('Введите строку');
readln(s);
l:=length(s);
for i:=1 to n do begin
if s[i]='(' then
t:=i; {здесь присваивал номер найденной скобки}
if s[i]=')' then
y:=i; {так же, как и выше}
delete (s,t,i); {у меня получается, что он удаляет с открывающей скобки и всё что находится вправо, а левая часть до скобки остается нетронутой}
end;
writeln('Данный результат =', s);
readln;
end.

Помогите решить задачу на Паскале.

Дана строка.Перенести последнюю букву слова в начало слова

Помогите решить задачу на паскале: в двумерном массиве хранятся результаты (время в минутах), показанные каждым из 12 автогонщиков на каждом из

10 этапов соревнований «Формула-1». После 10 этапа участник с порядковым номером 4 выбыл из соревнований. Изменить массив так, чтобы в нем не было результатов бывшего гонщика.



Вы находитесь на странице вопроса "помогите решить задание на паскаль используя формат if.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.