Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Только первую задачу,очень срочно

5-9 класс

Настявасилька 07 июня 2014 г., 18:01:49 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Диmан
07 июня 2014 г., 19:51:48 (9 лет назад)

Program P1;
var 
i,j: byte; // переменные счетчика цикла
a: array[1..7,1..7] of byte; // непосредственно сам массив - двумерный размера 7Х7
begin
for i:=1 to 7 do // перебор по столбцам массива
begin
for j:=1 to 7 do // перебор по строкам  массива
begin
if ((i=1) or (i=7)) and ((j=1) or (j=7)) then a[i,j]:=0 //проверяем индекс массива - если это угловой элемент, то он равен 0, в противном случае - 1
else a[i,j]:=1;
write (a[i,j],' '); // выводим строку элементов 
end;
writeln; // делаем переход на следующую строчку для вывода новой строки.
end;
end.

+ 0 -
Moxinur49
07 июня 2014 г., 20:32:49 (9 лет назад)

Программа должна сама формировать данный массив?

+ 0 -
Оля1801
07 июня 2014 г., 23:20:08 (9 лет назад)

И на каком языке?

+ 0 -
настенка2005
08 июня 2014 г., 1:57:10 (9 лет назад)

Нет,должен вводить.Паскаль

Ответить

Читайте также

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

ОЧЕНЬ СРОЧНО!!!!!!!

По каналу один за другим идут пароходы "Обь" и "Восток". Навстречу им идут один за другим пароходы "Мир" и "Енисей". Канал такой ширины, что два парохода в нем разойтись не могут. Но с одной стороны канал имеет расширение, в котором может поместиться один пароход. Как можно пароходам разойтись и продолжить свой путь?
Изобразите решение в виде схемы.ЗАРАНЕЕ СПАСИБО!(объясните,кто как может,очень срочно)

Помогите решить задачу, очень срочно !!!

Дан произвольный треугольник ABC, для которого определен следующий набор характерных параметров: a,b,c - стороны треугольника, альфа, бета, гамма - углы (в градусах), h - высота, опущенная на сторону c, S - площадь, P - периметр треугольника. По трем заданным параметрам вычислить все остальные возможные сочетания параметров: а, b, S. Записать в паскале.

Ребят,ОЧЕНЬ ОЧЕНЬ СРОЧНО!! хотя бы три решите 1 задача.

Какое количество информации требуется для кодировки Азбуки Морзе?

Задача 2.
Имеется монохромная фотография, информационный обьем которой 1000 байт, и высотой 80 пикселей. Во сколько раз уменьшится ее информационный обьем, если уменьшить ее ширину на 90 пикселей?

Задача 3.
Сколько дискет понадобится для копирования файла обьемом 11,5 Гигабайт? (Дополнительный балл: определить высоту стопки этих дискет в сантиметрах).

Задача 4.
Определите информационный обьем задачи: Ехал поезд из четырёх вагонов. Два спереди и один сзади. В среднем вагоне ехал брюнет, а в первом блондин. Решил блондин перейти в последний вагон, а рыжий в первый. Каждый двигался со скоростью два км в час. Скорость поезда никак не влияла на их самочувствие. Сколько времени им понадобится, чтобы одновременно посмотреть в глаза красавице в среднем вагоне? Кого она выберет в попутчики?

Задача 5.
Имеется коробка размером 25x20x30 сантиметров. Определите ее информационный обьем.

Пожалуйста, решите задачи по информатике , прошу ,очень срочно нужно а то за четверть будет плохая оценка ! Вот задачи : 1. Данны два массива из 10

элементов. Получить третий, элементы которого равны сумме соотвествующих элементов первого и второго массивов. (Qbasic)



Вы находитесь на странице вопроса "Только первую задачу,очень срочно", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.