Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Дан файл f, компоненты которого являются целыми числами.

10-11 класс

Найти количество квадратов нечетных чисел среди компонент файла. Записать это значение в начало нового файла g. Остальные значения переписать из исходного файла f.

Dencik03 18 мая 2014 г., 14:49:14 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Плов789
18 мая 2014 г., 15:49:22 (9 лет назад)

var
  n,s,x:integer;
  f,g:file of integer;
begin
assign(f,'d:\f.txt');
reset(f);
while not eof(f) do
  begin
  read(f,n);
  x:=Trunc(sqrt(n));
  if (x*x=n) and (x mod 2=1) then s:=s+1;
  end;
assign(g,'d:\g.txt'); 
rewrite(g);
write(g,s);
reset(f);
while not eof(f) do
  begin
  read(f,n);
  write(g,n);
  end;
close(f);
close(g);
end.

Ответить

Читайте также

Нужно написать программу... Задание: Адрес, запрашиваемый пользователем, обычно состоит из четырех частей, из которых первые три

являются доменными именами различного уровня и разделены точками, а последняя отделена от них двоеточием и является портом, к которому обращается пользователь. Например, при обращении пользователя к www.ifmo.ru:8080 слово ru является доменным именем первого уровня, слово ifmo — доменным именем второго уровня, слово www — доменным именем третьего уровня, а 8080 является портом.

Вам необходимо по списку запросов пользователей в таком формате перечислить все различные порты, к которым обращались пользователи.

Формат входного файла

В первой строке входного файла input.txt находится одно натуральное число n (1 ≤ n ≤ 100) — количество адресов в данном вам списке. В следующих n строках содержатся сами адреса в формате, описанном выше.

Все доменные имена всех уровней состоят только из строчных букв латинского алфавита, а порты — только из цифр. Длина любого данного вам адреса не превышает 250 символов.

Формат выходного файла

В первой строке выходного файла output.txt выведите одно целое число k — количество различных портов, к которым обращались пользователи. В следующих k строках выведите сами порты. Каждый порт должен быть выведен ровно один раз в отдельной строке. Порты могут быть выведены в любом порядке.

Пример входных и выходных данных

input.txt


3
www.ifmo.pl:3389
www.ya.pl:65535
www.ifmo.kz:3389

output.txt

2
65535
3389

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

Однажды, посетив магазин канцелярских товаров, Вася купил X карандашей, Y ручек и Z фломастеров. Известно, что цена ручки на 2 рубля больше цены

карандаша и на 7 рублей меньше цены фломастера. Также известно, что стоимость карандаша составляет 3 рубля. Требуется определить общую стоимость покупки.

Входные данные

В единственной строке входного файла INPUT.TXT записаны три натуральных числа X, Y и Z через пробел, каждое из которых не превышает 109.

Выходные данные

В выходной файл OUTPUT.TXT выведите одно целое число – стоимость покупки в рублях.



Вы находитесь на странице вопроса "Дан файл f, компоненты которого являются целыми числами.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.