Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите с программой:Дана

5-9 класс

сторона равностороннего треугольника. Найти площадь этого треугольника, его
высоту, радиусы вписанной и описанной окружностей. В программе Microsoft Visual Studio C#

ира5в 25 янв. 2015 г., 13:11:10 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sherepanovapolina
25 янв. 2015 г., 14:11:01 (9 лет назад)

[STAThread]
        static void Main()
        {
            double a = double.Parse(Console.ReadLine());
            double h, r, R, S;
            h = Math.Sqrt(3) / 2 * a;
            S = 0.5 * a * h;
            r =  (2 * S) / (3 * a);
            R = Math.Pow(a, 3) / (4 * S);
            Console.WriteLine("h = {0}", h);
            Console.WriteLine("S = {0}", S);
            Console.WriteLine("r = {0}", r);
            Console.WriteLine("R = {0}", R);
            Console.ReadKey(false);
        }

Ответить

Другие вопросы из категории

Из чего

состоит адрес электронной почты?


1) имени
сервера, имени ящика, страны;

Помогите решить задания. СРОЧНЯК!

1. Задан массив целых чисел. Вычислить суммы нечетных и отрицательных элементов.
2.Задана матрица целых чисел. Вычислить сумму элементов расположенных на главной и побочной диагоналях.
И это на с++

Приведите примеры:

Отношение между двумя объектами-......
Отношение между объектом и множеством объектов-.......
Отношение между двумя множествами объектов-........

Читайте также

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

Даны числа a,b,c. Составить программу, выводящую на экран сообщение, в зависимости от того какой треугольник можно построить с такими длина сторон:

равносторонний,равнобедренный или какой либо другой.

Вот ещё одна

Составить программу:Даны а,b,c-целые числа.Если они большн 0-вычислите сумму их квадратов;а если хотя бы одно из них четно-вычислите их сумму и произведение.

Пожалуйста ребят.

Помогите написать программу в С++,пожалуйста. ↓↓↓↓

Дан целочисленный массив из 40 элементов. Элементы массива могут принимать произвольные целые значения.Напишите программу,которая находит и выводит сумму наибольшей возрастающей последовательности подряд идущих элементов.

1.Написать программу, которая вычисляет частное двух чисел. Программа должна проверять правильность введенных пользователем данных и, если они неверные

(делитель равен нулю), вы давать сообщение об ошибке. Ниже приведен рекомендуемый вид экрана во время выполнения программы (данные, введенные пользователем, выделены полужирным шрифтом).
Вычисление частного.
Введите в одной строке делимое и делитель,
затем нажмите <enter>.
-> 12 О
Вы ошиблись. Делитель не должен быть равен нулю.

Помогите с программой по информатике

Найти средний рост класса. Написать программу. 10 человек
Самый наименьший рост 162 самый высокий 170



Вы находитесь на странице вопроса "Помогите с программой:Дана", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.