Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Помогите срочно , заранее спасибо номер 3

5-9 класс

Muhanbetkalieva 26 авг. 2013 г., 20:12:15 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Virus4212
26 авг. 2013 г., 21:39:55 (10 лет назад)

var a:array[1..3]of integer;
     s,i,max,k,p:integer;
begin
 for i:=1 to 3 do
  read(a[i]);
 for i:=1 to 2 do
  begin
   max:=a[i];
   p:=i;
   for k:=i+1 to 3 do
    if a[k]>max then 
     begin
      max:=a[k];
      p:=k;
     end;
   a[p]:=a[i];
   a[i]:max;
  end;
 s:=a[1]+a[2];
 writeln('summa:',s);
end.

Ответить

Другие вопросы из категории

1) В коробке лежат 32 клубка шерсти. Среди них 4 красных. Сколько информации несет сообщение о том, что достали клубок красной шерсти? 2) в

коробке лежат 64 цветных карандаша. Сообщение о том, что достали белый карандаш, несет 4 бита информации. Сколько белых карандашей было в корзине?

3) В ящике лежат перчатки(белые и черные). Среди них-две пары черных. Сообщение о том, что из ящика достали пару черных перчаток, несет 4 бита информации. Сколько всего пар перчаток в ящике?

ПОМОГИИИИТЕ

Напишите программу, которая в последовательности натуральных

чисел определяет максимальное число, кратное 5. Программа
получает на вход количество чисел в последовательности, а затем сами
числа. В последовательности всегда имеется число, кратное 5.
Количество чисел не превышает 1000. Введённые числа не превышают
30 000.
Программа должна вывести одно число – максимальное число, кратное 5.

Читайте также

Помогите!!!

К завтра надо, срочно!!!
Заранее спасибо!
какое минимальное количество бит необходимо для кодирования двоичным кодом 150 квартирного дома

Пожалуйста помогите срочно. Напишите программу в паскале для 9класса отображающую третий закон Ньютона. Если не можете сюда кинуть, киньте на мой мейл -

[email protected] заранее спасибо



Вы находитесь на странице вопроса "Помогите срочно , заранее спасибо номер 3", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.