Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

1. дано натуральное двух значное число определить будет ли цыфра десятков больше чем цыфра единиц.Тема паскаль 2) даны два

5-9 класс

натуральных числа вывести на экран то из них у которого цыфра меньше. пожалуйста решите 2 задачи

Masha23041993 02 нояб. 2013 г., 6:03:06 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dimon357
02 нояб. 2013 г., 7:03:09 (10 лет назад)

Program p1;

Uses crt;

Var x:byte;

Begin

 Write('Введите x, x=');

 Readln(x);

 If x mod 10> x div 10 then

 Writeln('Число единиц больше числа десятков') else

  If x mod 10< x div 10 then

  Writeln('Число десятков больше числа единиц ') else

   Writeln('Число десятков равно числу единиц ')

End.

 

Скажите, что за цифры сравниваются во втором задании?
Я скину решение Вам  в личные сообщения.

+ 0 -
Sofua
02 нояб. 2013 г., 8:01:37 (10 лет назад)

2)var a, b:integer;

begin

writeln('Введите 2 числа');

readln(a, b);

if a<b then writeln('min=', a)

else writeln('min=', b);

readln;

end.

 

Ответить

Другие вопросы из категории

реализуйте решение задачи, программируя на Паскале. Программа морскрй бой. Учитель задумывает два числа от 0 до 9. (Водятся учителемв Вашу программу). И

грок пытается их угадать, вводя свои числа. Если они совпали(в указанном порядке), то игрок выиграл (выводится сообщение-"попал"). Иначе-сообщение "мимо".

Маму дяди Фёдора выстроились встречать в одну шеренгу Матроскин, Шарик, дядя Фёдор, Галчонок и папа. Матроскин стоит после дяди Федора, Шарик

стоит до Матроскина, но после Галчонка. Галчонок – до дяди Фёдора, но он стоит не первым. Каким по счету в шеренге стоит папа, если считать слева направо?

Читайте также

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!

Вариант № 2 1)Подсчитать сумму квадратов всех отрицательных и четных чисел из 10 вводимых. 2) Даны натуральные числа от 35 до 87.

Найти и напечатать те из них, которые при делении на 7 дают остаток 1, 2 или 5.

3)Дано целое число а и натуральное (целое неотрицательное) число n. Вычислить а в степени n, используя в программе лишь операцию умножения.

4)Введите последовательность из n целых чисел. Найти наибольшее из всех отрицательных чисел. Вывести его значение и порядковый номер.

5)Вычислите: 99-97+95-93+91-89+....+7-5+3-1.

6)Доказать (путем перебора возможных значений), что для любых величин А, В, С типа Boolean следующая пара логических выражений имеет одинаковые значения (эквивалентны): A OR (B AND C) и (A OR B) AND (A OR C).



Вы находитесь на странице вопроса "1. дано натуральное двух значное число определить будет ли цыфра десятков больше чем цыфра единиц.Тема паскаль 2) даны два", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.