Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

1.Дан массив, вывести с клавиатуры размерность. отрицательные числа массива разделить на 2 и вывести на экран. Пожалуйста помогите!

10-11 класс

C4rrick 13 февр. 2015 г., 4:49:23 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Anna588
13 февр. 2015 г., 5:46:06 (9 лет назад)

var
  a: array of integer;
  n, i: integer;
begin
  randomize;
  write('Введите размерность массива: ');
  readln(n);
  Setlength(a, n);
  writeln('Массив: ');
  for i := 0 to n - 1 do
   begin
    a[i] := random(21) - 10;
    write(a[i]:5);
   end;
  writeln;
  writeln('Результат деления отрицательных элементов на 2: ');
  for i := 0 to n - 1 do
  begin
    if a[i] < 0 then write(a[i] / 2:5)
    else write(a[i]:5)
  end;
end.

Ответить

Другие вопросы из категории

Вычеркивание цифры

Дано натуральное число,
содержащее не более N (0<N£9) цифр. Вычеркнув в нем одну
цифру, получить наибольшее число. При этом порядок цифр в числе менять нельзя.

Помогите Прошу)

Читайте также

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

Паскаль. 12.Дан массив А(3*4). Найти сумму первых отрицательных элементов в каждом столбце. 13.Даны два массива А(3*3)

и В(3*3). Вывести на экран тот из них, у которого меньше сумма элементов главной диагонали.

17.Дан массив А(3*4). Заменить все отрицательные элементы на противоположные.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

Ввести одномерный массив A , вывести его. Найти произведение

элементов стоящих слева и справа от минимального элемента массива.
Разделить на найденное произведение минимум и максимум. Изменённый
массив вывести.
Вот начало:

program ABC;
const Nmass=100;
var A:array[1..Nmass] of integer;
N,i,k,max,min: byte;
buf:integer;
begin
cls;
//ручной ввод массива
writeLn('Введите число элементов в массиве A');
readLn(N);
writeLn('Вводим элементы массива A:');
for i:=1 to N do
begin
write('A[',i,']=');
readLn(A[i]);
end;
//вывод массива до измененния
writeLn('Исходный массив A:');
for i:=1 to N do
write(A[i]:5);
writeLn;




Вы находитесь на странице вопроса "1.Дан массив, вывести с клавиатуры размерность. отрицательные числа массива разделить на 2 и вывести на экран. Пожалуйста помогите!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.