Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

1)Дан

10-11 класс

одномерный массив А[N], - целых чисел.
Заменить все большие 7 члены массива числом 7. Найти количество таких членов.

КАРАСАТУЛЯ 26 июня 2014 г., 4:30:11 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Domonik1199
26 июня 2014 г., 5:22:22 (9 лет назад)

var a:array of integer;
n,i,k:integer;
begin
readln(n);
setlength(a,n);
for i:=0 to n-1 do begin
read(a[i]);
if a[i]>7 then begin a[i]:=7; k+=1; end;
end;
writeln(k);
for i:=0 to n-1 do
write(a[i],' ');
end.

var a:array[1..10] of integer;
i,p:integer;
begin
p:=1;
for i:=1 to 10 do begin
read(a[i]);
p*=a[i];
end;
writeln(p);
end.

var a:array of integer;
i,sr,n:integer;
begin
readln(n);
setlength(a,n);
for i:=0 to n-1 do begin
read(a[i]);
sr+=a[i];
end;
writeln(sr/n:3:2);
end.

var a:array of integer;
n,i,k:integer;
begin
readln(n);
setlength(a,n);
for i:=0 to n-1 do begin
read(a[i]);
if a[i]>0 then k+=1;
end;
writeln(k);
end.

var a:array of integer;
n,i,k1,k2:integer;
begin
readln(n);
setlength(a,n);
for i:=0 to n-1 do begin
read(a[i]);
if odd(a[i]) then k2+=1
else k1+=1;
end;
writeln(k1,' ',k2);
end.

Ответить

Другие вопросы из категории

СРОЧНО, ПОЖАЛУЙСТА, НАПИШИТЕ КТО-НИБУДЬ, НА ЗАВТРА НАДО,

УМОЛЯЮ, ТОЛЬКО ПРАВИЛЬНО!!!Я УЖЕ 30 РАЗ ЭТО ЗАДАНИЕ ПОСЫЛАЮ, НАПИШИТЕ!!! КТО СМОЖЕТ, ТОЛЬКО ПРАВИЛЬНО! КТО, ЧТО СМОЖЕТ, НО НАДО ВСЕ, НА ЗАВТРА!!!

Читайте также

Данные, объемом 16 Мбайт, поступают на компьютер по линии со скоростью передачи данных 32 Мбит/с. После получения 4 Мбайт компьютер начинает одновременно

передавать эти данные по другой линии связи со скоростью 4 Мбит/с. Сколько секунд пройдет от начала приема данных по высокоскоростному каналу до полной передачи их по низкоскоростному каналу?

Дано целое положительное число. Проверить истинность высказывания: «данное число является нечетным трехзначным».

Входные данные: ввести одно целое положительное число a ((1<=a<=1000).
Выходные данные: вывести слово «true» если приведенное высказывание для предложенных исходных данных является истинным или «false» в противном случае.

C++Написать программу вычисления объема параллелепипеда. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные

пользователем, выделены полужирным шрифтом).

Вычисление объема параллелепипеда.

Введите исходные данные:

Длинна (см): 9

Ширина (см): 7.5

Высота (см): 5



Вы находитесь на странице вопроса "1)Дан", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.