Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

) Дана последовательность чисел Стирлинга. Числа Стирлинга S(n,k) определены для 0≤k≤n и удовлетворяют следующим соотношениям:

10-11 класс

S(0,0)=1,
S(n,0)=0 для n>0,
S(n,n)=1 для n>0,
Иначе S(n,k)=k*S(n-1,k)+S(n-1,k-1).
Для n=15, k=13 найти и вывести число Стирлинга S(n,k).

ZaraWarn 21 июля 2013 г., 3:56:28 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Qwertyer123
21 июля 2013 г., 5:40:46 (10 лет назад)

function ster(n,k:integer):integer;
begin
if k=0 then
  if n=0 then ster:=1
  else ster:=0
else if n=k then
       ster:=1
       else  ster:=k*ster(n-1,k)+ster(n-1,k-1)
end;

begin
writeln(ster(15,13));
end.

Ответить

Другие вопросы из категории

1)Какое количество информации несёт сообщние о том, что встреча назначена на 9:00? 2) За четверть ученик получил 100 оценок. Сообщение о том,

что он получил тройку несёт 3 бита информации. Сколько троек получил ученик за четверть?

Помогите пожалуйста

С клавиатуры вводятся 5 символов.Подсчитать количество знаков препинания.в VBA

Читайте также

1. В последовательности чисел подсчитать произведение чисел, кратных 3.

2. В последовательности чисел сравнить, что больше сумма положительных или про-изведение отрицательных.
3. В последовательности чисел определить предпоследнее отрицательное число. (При решении введите дополнительную переменную для хранения предпоследнего отрицательного числа).

Для кодирования номеров автомобилей принята следующая структура данных: Номер региона (двузначное число от 00 до 99), серия (комбинация из трех букв из

набора «А, В, Е, К, М, Н, О, Р, С, Т, У, Х»), номер (трехзначное число от 000 до 999). При создании базы данных автомобильных номеров Петя решил хранить каждый номер в виде массива из 8 символов (два символа на номер региона, три символа на серию и три символа на номер), кодируя каждый символ с помощью однобайтной кодировки ASCII. Вася решил уменьшить объем хранимых данных и принял решение хранить каждый номер в виде трех чисел – одно число для номера региона, одно число для серии (представив все возможные серии в виде натуральных чисел) и одно число для номера. Каждое число Вася будет хранить отдельно, используя для его кодирования минимально возможное число бит. На сколько бит уменьшится объем памяти, необходимый для хранения одного произвольного номера, в варианте кодирования Васи по сравнению с вариантом кодирования Пети? В ответе укажите целое число.

Дана последовательность

не более N
ненулевых целых чисел, последним числом в последовательности является
0. Ввести эту последовательность в одномерный массив и
вычислить хаpактеристики
.Найти порядковые номера и сумму двух наибольших элементов. ( в Паскаль )



Вы находитесь на странице вопроса ") Дана последовательность чисел Стирлинга. Числа Стирлинга S(n,k) определены для 0≤k≤n и удовлетворяют следующим соотношениям:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.